summaryrefslogtreecommitdiffstats
path: root/python/jsonpointer
diff options
context:
space:
mode:
Diffstat (limited to 'python/jsonpointer')
-rw-r--r--python/jsonpointer/jsonpointer.SlackBuild29
-rw-r--r--python/jsonpointer/jsonpointer.info10
2 files changed, 10 insertions, 29 deletions
diff --git a/python/jsonpointer/jsonpointer.SlackBuild b/python/jsonpointer/jsonpointer.SlackBuild
index 413aea70dc..bfc8039a49 100644
--- a/python/jsonpointer/jsonpointer.SlackBuild
+++ b/python/jsonpointer/jsonpointer.SlackBuild
@@ -2,7 +2,8 @@
# Slackware build script for jsonpointer
-# Copyright 2020 Alan Aversa
+# Copyright 2020 Alan Aversa <alan_avNOersa@lSPAMavabit.com>
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jsonpointer
-VERSION=${VERSION:-2.0}
+VERSION=${VERSION:-3.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -79,16 +63,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-else
- python setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS LICENSE.txt README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/jsonpointer/jsonpointer.info b/python/jsonpointer/jsonpointer.info
index af53a5b77c..346a1a40f5 100644
--- a/python/jsonpointer/jsonpointer.info
+++ b/python/jsonpointer/jsonpointer.info
@@ -1,10 +1,10 @@
PRGNAM="jsonpointer"
-VERSION="2.0"
+VERSION="3.0.0"
HOMEPAGE="https://pypi.org/project/jsonpointer/"
-DOWNLOAD="https://files.pythonhosted.org/packages/52/e7/246d9ef2366d430f0ce7bdc494ea2df8b49d7a2a41ba51f5655f68cfe85f/jsonpointer-2.0.tar.gz"
-MD5SUM="741b98d0e693b08b5e44e0a9da5a7bb7"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/j/jsonpointer/jsonpointer-3.0.0.tar.gz"
+MD5SUM="9a0b3e940bbd65f544f41018a904991f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Alan Aversa"
-EMAIL="alan_avNOersa@lSPAMavabit.com"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu@protonmail.com"