summaryrefslogtreecommitdiffstats
path: root/python/numpydoc
diff options
context:
space:
mode:
Diffstat (limited to 'python/numpydoc')
-rw-r--r--python/numpydoc/numpydoc.SlackBuild12
-rw-r--r--python/numpydoc/numpydoc.info10
2 files changed, 13 insertions, 9 deletions
diff --git a/python/numpydoc/numpydoc.SlackBuild b/python/numpydoc/numpydoc.SlackBuild
index 561a1b7962..fcc924288e 100644
--- a/python/numpydoc/numpydoc.SlackBuild
+++ b/python/numpydoc/numpydoc.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for numpydoc
-# Copyright 2015-2021 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2015-2024 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=numpydoc
-VERSION=${VERSION:-1.1.0}
+VERSION=${VERSION:-1.7.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,9 +79,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
+
+find $PKG -print1 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/numpydoc/numpydoc.info b/python/numpydoc/numpydoc.info
index 81b5fb5113..fee5d365c8 100644
--- a/python/numpydoc/numpydoc.info
+++ b/python/numpydoc/numpydoc.info
@@ -1,10 +1,10 @@
PRGNAM="numpydoc"
-VERSION="1.1.0"
+VERSION="1.7.0"
HOMEPAGE="https://github.com/numpy/numpydoc"
-DOWNLOAD="https://files.pythonhosted.org/packages/3d/fb/a70f636102045fc646656f2221c7fcdf92f7a9d71ba7c9875a949a58b3e8/numpydoc-1.1.0.tar.gz"
-MD5SUM="2f05c4592e007b7a1fa37ddcb7e0e91b"
+DOWNLOAD="https://files.pythonhosted.org/packages/76/69/d745d43617a476a5b5fb7f71555eceaca32e23296773c35decefa1da5463/numpydoc-1.7.0.tar.gz"
+MD5SUM="7018ef86ed43dccaeb743127a2b3f542"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="Sphinx Jinja2"
+REQUIRES="python3-setuptools-opt Sphinx python3-tabulate"
MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+EMAIL="dslackw@gmail.com"