summaryrefslogtreecommitdiffstats
path: root/python/objgraph
diff options
context:
space:
mode:
Diffstat (limited to 'python/objgraph')
-rw-r--r--python/objgraph/README3
-rw-r--r--python/objgraph/objgraph.SlackBuild18
-rw-r--r--python/objgraph/objgraph.info8
3 files changed, 8 insertions, 21 deletions
diff --git a/python/objgraph/README b/python/objgraph/README
index 0ae9cbce60..a188ef46c1 100644
--- a/python/objgraph/README
+++ b/python/objgraph/README
@@ -1,2 +1,5 @@
objgraph is a module that lets you visually explore Python object
graphs.
+
+Graphviz (https://graphviz.org) is an optional dependency. It is needed
+for drawing the graphs.
diff --git a/python/objgraph/objgraph.SlackBuild b/python/objgraph/objgraph.SlackBuild
index 5e96846721..714df16ef1 100644
--- a/python/objgraph/objgraph.SlackBuild
+++ b/python/objgraph/objgraph.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=objgraph
-VERSION=${VERSION:-3.5.0}
+VERSION=${VERSION:-3.6.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -47,20 +47,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -76,8 +62,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
-
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/python/objgraph/objgraph.info b/python/objgraph/objgraph.info
index dd1ed39dd5..87d97f3fa6 100644
--- a/python/objgraph/objgraph.info
+++ b/python/objgraph/objgraph.info
@@ -1,10 +1,10 @@
PRGNAM="objgraph"
-VERSION="3.5.0"
+VERSION="3.6.1"
HOMEPAGE="https://mg.pov.lt/objgraph/"
-DOWNLOAD="https://files.pythonhosted.org/packages/08/f9/05c2b413d39e86772a4dda63f78232a3fc62f2545cf5f3e23acc6cabaef7/objgraph-3.5.0.tar.gz"
-MD5SUM="31ddfc309dd9ae41ddc50763737fdc6f"
+DOWNLOAD="https://files.pythonhosted.org/packages/49/c4/bd177f5a3c2730f939d0ee5949cb0a6a12402863bf3d482cb9e79f296b57/objgraph-3.6.1.tar.gz"
+MD5SUM="dbb00c59c5fc4facc17df4c0c3c71eec"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="graphviz"
+REQUIRES=""
MAINTAINER="Markus Rinne"
EMAIL="markus.ka.rinne@gmail.com"