summaryrefslogtreecommitdiffstats
path: root/python/pyblake2/pyblake2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyblake2/pyblake2.SlackBuild')
-rw-r--r--python/pyblake2/pyblake2.SlackBuild23
1 files changed, 9 insertions, 14 deletions
diff --git a/python/pyblake2/pyblake2.SlackBuild b/python/pyblake2/pyblake2.SlackBuild
index a21bb6414d..e866d87ca0 100644
--- a/python/pyblake2/pyblake2.SlackBuild
+++ b/python/pyblake2/pyblake2.SlackBuild
@@ -36,17 +36,16 @@ if [ -z "$ARCH" ]; then
*) ARCH=$( uname -m ) ;;
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
+
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-TMP=${TMP:-/tmp}
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+
if [ "$ARCH" = "i586" ]; then
MOSCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
@@ -60,7 +59,9 @@ else
MOSCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
+
set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
@@ -68,23 +69,17 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
+
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- # Python 2.7 will be droped in the future.
-if $(python2 -c 'import sys' 2>/dev/null); then
- python2 setup.py install --root=$PKG
- else
- python setup.py install --root=$PKG
-fi
+# Python 2.7 will be dropped in the future.
+python2 setup.py install --root=$PKG
-# Replacement of python-2.x Python3.x check presence and build if found.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true