summaryrefslogtreecommitdiffstats
path: root/python/pycrypto
diff options
context:
space:
mode:
Diffstat (limited to 'python/pycrypto')
-rw-r--r--python/pycrypto/README3
-rw-r--r--python/pycrypto/pycrypto.SlackBuild82
-rw-r--r--python/pycrypto/pycrypto.info10
-rw-r--r--python/pycrypto/slack-desc19
4 files changed, 0 insertions, 114 deletions
diff --git a/python/pycrypto/README b/python/pycrypto/README
deleted file mode 100644
index ed20575779..0000000000
--- a/python/pycrypto/README
+++ /dev/null
@@ -1,3 +0,0 @@
-This is a collection of both secure hash functions (such as MD5 and SHA),
-and various encryption algorithms (AES, DES, IDEA, RSA, ElGamal, etc.).
-The package is structured to make adding new modules easy.
diff --git a/python/pycrypto/pycrypto.SlackBuild b/python/pycrypto/pycrypto.SlackBuild
deleted file mode 100644
index 763f84009a..0000000000
--- a/python/pycrypto/pycrypto.SlackBuild
+++ /dev/null
@@ -1,82 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for pycrypto
-
-# Copyright 2008-2012 Heinz Wiesinger, Amsterdam, The Netherlands
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=pycrypto
-VERSION=${VERSION:-2.6.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ACKS ChangeLog COPYRIGHT README TODO Doc \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/pycrypto/pycrypto.info b/python/pycrypto/pycrypto.info
deleted file mode 100644
index afc1b7237f..0000000000
--- a/python/pycrypto/pycrypto.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pycrypto"
-VERSION="2.6.1"
-HOMEPAGE="https://www.dlitz.net/software/pycrypto/"
-DOWNLOAD="https://pypi.python.org/packages/source/p/pycrypto/pycrypto-2.6.1.tar.gz"
-MD5SUM="55a61a054aa66812daf5161a0d5d7eda"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Heinz Wiesinger"
-EMAIL="pprkut@slackbuilds.org"
diff --git a/python/pycrypto/slack-desc b/python/pycrypto/slack-desc
deleted file mode 100644
index 2e47fafedd..0000000000
--- a/python/pycrypto/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pycrypto: pycrypto (Python Cryptography Toolkit)
-pycrypto:
-pycrypto: This is a collection of both secure hash functions (such as MD5 and
-pycrypto: SHA), and various encryption algorithms (AES, DES, IDEA, RSA,
-pycrypto: ElGamal, etc.). The package is structured to make adding new
-pycrypto: modules easy.
-pycrypto:
-pycrypto: Homepage: http://www.pycrypto.org
-pycrypto:
-pycrypto:
-pycrypto: