summaryrefslogtreecommitdiffstats
path: root/python/pymongo
diff options
context:
space:
mode:
Diffstat (limited to 'python/pymongo')
-rw-r--r--python/pymongo/README1
-rw-r--r--python/pymongo/pymongo.SlackBuild18
-rw-r--r--python/pymongo/pymongo.info12
-rw-r--r--python/pymongo/slack-desc2
4 files changed, 14 insertions, 19 deletions
diff --git a/python/pymongo/README b/python/pymongo/README
index cfa106b153..711daff44c 100644
--- a/python/pymongo/README
+++ b/python/pymongo/README
@@ -3,4 +3,3 @@ database from Python. The bson package is an implementation of
the BSON format for Python (http://bsonspec.org). The pymongo
package is a native Python driver for MongoDB. The gridfs package
is a gridfs implementation on top of pymongo.
-(http://www.mongodb.org/display/DOCS/GridFS+Specification)
diff --git a/python/pymongo/pymongo.SlackBuild b/python/pymongo/pymongo.SlackBuild
index 08f64ae20f..f02e19d718 100644
--- a/python/pymongo/pymongo.SlackBuild
+++ b/python/pymongo/pymongo.SlackBuild
@@ -2,8 +2,8 @@
# Slackware build script for pymongo
+# Copyright 2015-2024 Dimitris Zlatanidis Orestiada, Greece
# Copyright 2013-2014 Christoph Willing, Australia
-# Copyright 2015-2019 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pymongo
-VERSION=${VERSION:-3.10.0}
+VERSION=${VERSION:-4.7.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -80,18 +77,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md doc/tutorial.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/pymongo/pymongo.info b/python/pymongo/pymongo.info
index f38620edec..97cf59b5b4 100644
--- a/python/pymongo/pymongo.info
+++ b/python/pymongo/pymongo.info
@@ -1,10 +1,10 @@
PRGNAM="pymongo"
-VERSION="3.10.0"
-HOMEPAGE="https://pypi.python.org/pypi/pymongo"
-DOWNLOAD="https://files.pythonhosted.org/packages/5d/86/bfcec2a1c99e52344530e581a89871738bdcbf2c8f2ba681ad891e0980f1/pymongo-3.10.0.tar.gz"
-MD5SUM="fb98d896f0eb14d9b4fe9baac24d772a"
+VERSION="4.7.2"
+HOMEPAGE="https://github.com/mongodb/mongo-python-driver"
+DOWNLOAD="https://files.pythonhosted.org/packages/af/7a/3401c2f16bff666e7b2d0416a345e2cb4059d27c98cb80aad66cb82dda69/pymongo-4.7.2.tar.gz"
+MD5SUM="6ebe86590829e8fea43c384e299aeb4b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-setuptools-opt"
MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+EMAIL="dslackw@gmail.com"
diff --git a/python/pymongo/slack-desc b/python/pymongo/slack-desc
index 9a5631452d..49b7a87d14 100644
--- a/python/pymongo/slack-desc
+++ b/python/pymongo/slack-desc
@@ -13,7 +13,7 @@ pymongo: database from Python. The bson package is an implementation of
pymongo: the BSON format for Python (http://bsonspec.org). The pymongo
pymongo: package is a native Python driver for MongoDB. The gridfs package
pymongo: is a gridfs implementation on top of pymongo.
-pymongo: (http://www.mongodb.org/display/DOCS/GridFS+Specification)
pymongo:
+pymongo: Homepage: https://github.com/mongodb/mongo-python-driver
pymongo:
pymongo: