summaryrefslogtreecommitdiffstats
path: root/python/pynacl
diff options
context:
space:
mode:
Diffstat (limited to 'python/pynacl')
-rw-r--r--python/pynacl/pynacl.SlackBuild13
-rw-r--r--python/pynacl/pynacl.info2
2 files changed, 4 insertions, 11 deletions
diff --git a/python/pynacl/pynacl.SlackBuild b/python/pynacl/pynacl.SlackBuild
index 6736a2fc73..655f9bc0ca 100644
--- a/python/pynacl/pynacl.SlackBuild
+++ b/python/pynacl/pynacl.SlackBuild
@@ -41,15 +41,12 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-TMP=${TMP:-/tmp}
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -68,12 +65,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Python 2.7 will be droped in the future.
-if $(python2 -c 'import sys' 2>/dev/null); then
- python2 setup.py install --root=$PKG
- else
- python setup.py install --root=$PKG
-fi
+# Python 2.7 will be dropped in the future.
+python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
diff --git a/python/pynacl/pynacl.info b/python/pynacl/pynacl.info
index 27f6dbe452..8fe4ae7fec 100644
--- a/python/pynacl/pynacl.info
+++ b/python/pynacl/pynacl.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://files.pythonhosted.org/packages/cf/5a/25aeb636baeceab15c8e57e6
MD5SUM="8c6c57893327a694c72510fb620e4744"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="cffi wheel"
+REQUIRES="cffi python2-wheel python3-wheel"
MAINTAINER="Pr. HORSTMANN"
EMAIL="wmh@eipg.fr"