summaryrefslogtreecommitdiffstats
path: root/python/python-colour/python-colour.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-colour/python-colour.SlackBuild')
-rw-r--r--python/python-colour/python-colour.SlackBuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/python/python-colour/python-colour.SlackBuild b/python/python-colour/python-colour.SlackBuild
index ba59094308..aa5be78569 100644
--- a/python/python-colour/python-colour.SlackBuild
+++ b/python/python-colour/python-colour.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-colour
-# Copyright 2021 Matt Dinslage, Springfield, MO
+# Copyright 2021-2024 Matt Dinslage, Springfield, MO
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-colour
VERSION=${VERSION:-0.1.5}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -81,7 +78,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+patch -p1 < $CWD/66.patch
# build python3
sed -i 's,python,python3,g' setup.py