summaryrefslogtreecommitdiffstats
path: root/python/python-evdev
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-evdev')
-rw-r--r--python/python-evdev/README8
-rw-r--r--python/python-evdev/python-evdev.SlackBuild45
-rw-r--r--python/python-evdev/python-evdev.info12
3 files changed, 28 insertions, 37 deletions
diff --git a/python/python-evdev/README b/python/python-evdev/README
index 5df3c5270f..9a2720d8a0 100644
--- a/python/python-evdev/README
+++ b/python/python-evdev/README
@@ -1,5 +1,3 @@
-python-evdev allows Python programs running in Linux to read and write input
-events. It provides bindings to both the generic input event interface (evdev)
-and the userspace input subsystem (Uinput).
-
-This will automatically build for Python 3 if it's available.
+python-evdev allows Python programs running in Linux to read and write
+input events. It provides bindings to both the generic input event
+interface (evdev) and the userspace input subsystem (Uinput).
diff --git a/python/python-evdev/python-evdev.SlackBuild b/python/python-evdev/python-evdev.SlackBuild
index a8c9ccd943..f18028d337 100644
--- a/python/python-evdev/python-evdev.SlackBuild
+++ b/python/python-evdev/python-evdev.SlackBuild
@@ -1,9 +1,10 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for python-evdev
# Copyright 2015 Dugan Chen, Canada <thedoogster@gmail.com>
-# Copyright 2020 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2020-2023 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023-2024 Erich Ritz, Jenks, Oklahoma, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -17,17 +18,21 @@
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=python-evdev
-SRCNAM=evdev
-VERSION=${VERSION:-1.3.0}
+VERSION=${VERSION:-1.7.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=evdev
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -37,25 +42,15 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -74,11 +69,9 @@ find -L . \
# ... but upstream shipped evdev-1.0.0 with 660 permissions everywhere, so:
find -L . -perm 660 -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -91,4 +84,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python-evdev/python-evdev.info b/python/python-evdev/python-evdev.info
index f11c15b90d..76e1d03ccc 100644
--- a/python/python-evdev/python-evdev.info
+++ b/python/python-evdev/python-evdev.info
@@ -1,10 +1,10 @@
PRGNAM="python-evdev"
-VERSION="1.3.0"
+VERSION="1.7.0"
HOMEPAGE="http://python-evdev.readthedocs.org/en/latest/"
-DOWNLOAD="https://pypi.python.org/packages/source/e/evdev/evdev-1.3.0.tar.gz"
-MD5SUM="05f9e900d6e11e1674475d2dd2668f0d"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/e/evdev/evdev-1.7.0.tar.gz"
+MD5SUM="ef6d242ed75a92f93022b8715c4c8fe5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
+REQUIRES="python3-setuptools-opt"
+MAINTAINER="Erich Ritz"
+EMAIL="erich.public@protonmail.com"