summaryrefslogtreecommitdiffstats
path: root/python/python-magic/python-magic.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-magic/python-magic.SlackBuild')
-rw-r--r--python/python-magic/python-magic.SlackBuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/python/python-magic/python-magic.SlackBuild b/python/python-magic/python-magic.SlackBuild
index 3a2cfabc0d..f2f5733870 100644
--- a/python/python-magic/python-magic.SlackBuild
+++ b/python/python-magic/python-magic.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for python-magic
+# Copyright 2023 Steven Voges <Oregon, USA>
# Copyright 2009-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
@@ -25,22 +26,19 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-magic
-VERSION=${VERSION:-0.4.15}
+VERSION=${VERSION:-0.4.27}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -66,11 +64,7 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python2 setup.py install --root=$PKG
-
-# Add Python3 support
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true