summaryrefslogtreecommitdiffstats
path: root/python/python-mysql-replication
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-mysql-replication')
-rw-r--r--python/python-mysql-replication/README2
-rw-r--r--python/python-mysql-replication/python-mysql-replication.SlackBuild20
-rw-r--r--python/python-mysql-replication/python-mysql-replication.info6
3 files changed, 6 insertions, 22 deletions
diff --git a/python/python-mysql-replication/README b/python/python-mysql-replication/README
index dc319c748f..2a7699768e 100644
--- a/python/python-mysql-replication/README
+++ b/python/python-mysql-replication/README
@@ -1,4 +1,2 @@
Pure Python Implementation of MySQL replication protocol build on top of
PyMYSQL.
-
-This will automatically build for Python 3 if it's available.
diff --git a/python/python-mysql-replication/python-mysql-replication.SlackBuild b/python/python-mysql-replication/python-mysql-replication.SlackBuild
index 0bc42e67cb..df6b14b1a4 100644
--- a/python/python-mysql-replication/python-mysql-replication.SlackBuild
+++ b/python/python-mysql-replication/python-mysql-replication.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for python-mysql-replication
# Copyright 2019-2022 Andrew Clemons, Wellington New Zealand
+# Copyright 2022-2024 Andrew Clemons, Tokyo Japan
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-mysql-replication
-SRCNAM=mysql-replication
-VERSION=${VERSION:-0.28}
+SRCNAM=mysql_replication
+VERSION=${VERSION:-1.0.9}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -48,20 +49,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -77,7 +64,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/python/python-mysql-replication/python-mysql-replication.info b/python/python-mysql-replication/python-mysql-replication.info
index ca2d55a560..42744fc9a1 100644
--- a/python/python-mysql-replication/python-mysql-replication.info
+++ b/python/python-mysql-replication/python-mysql-replication.info
@@ -1,8 +1,8 @@
PRGNAM="python-mysql-replication"
-VERSION="0.28"
+VERSION="1.0.9"
HOMEPAGE="https://github.com/julien-duponchelle/python-mysql-replication"
-DOWNLOAD="https://files.pythonhosted.org/packages/b0/f7/c91d9360192fcb476621cdba78a8bf0e49817580f36814361afaca8baf66/mysql-replication-0.28.tar.gz"
-MD5SUM="54be8f1e167df4cce9f3370faf830fec"
+DOWNLOAD="https://files.pythonhosted.org/packages/57/af/e23aa4e52a094e865554998112f0d94751072b1f076f16ac970ce93e6002/mysql_replication-1.0.9.tar.gz"
+MD5SUM="c937a241e848b5d316bba88b06279119"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="pymysql"