summaryrefslogtreecommitdiffstats
path: root/python/python-zipp
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-zipp')
-rw-r--r--python/python-zipp/python-zipp.SlackBuild31
-rw-r--r--python/python-zipp/python-zipp.info12
-rw-r--r--python/python-zipp/setup.py5
3 files changed, 14 insertions, 34 deletions
diff --git a/python/python-zipp/python-zipp.SlackBuild b/python/python-zipp/python-zipp.SlackBuild
index 3f39269b22..109e154d76 100644
--- a/python/python-zipp/python-zipp.SlackBuild
+++ b/python/python-zipp/python-zipp.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for python-zipp
+# Copyright 2023-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2019-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# Copyright 2022 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
@@ -26,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-zipp
-VERSION=${VERSION:-3.8.0}
+VERSION=${VERSION:-3.18.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -53,20 +51,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -74,18 +58,19 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cp $CWD/setup.py $SRCNAM-$VERSION
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-sed -i "s,^name =.*$,&\nversion = $VERSION," setup.cfg
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-zipp/python-zipp.info b/python/python-zipp/python-zipp.info
index 6fb99df1bd..549d99aa42 100644
--- a/python/python-zipp/python-zipp.info
+++ b/python/python-zipp/python-zipp.info
@@ -1,10 +1,10 @@
PRGNAM="python-zipp"
-VERSION="3.8.0"
+VERSION="3.18.1"
HOMEPAGE="https://github.com/jaraco/zipp"
-DOWNLOAD="https://files.pythonhosted.org/packages/cc/3c/3e8c69cd493297003da83f26ccf1faea5dd7da7892a0a7c965ac3bcba7bf/zipp-3.8.0.tar.gz"
-MD5SUM="8864ff5ed01cd28755cc87f1443dbc67"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/z/zipp/zipp-3.18.1.tar.gz"
+MD5SUM="35d5af28231d6464fe2c2bea05d306dd"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+REQUIRES="python3-setuptools-opt"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"
diff --git a/python/python-zipp/setup.py b/python/python-zipp/setup.py
deleted file mode 100644
index 0ae4555937..0000000000
--- a/python/python-zipp/setup.py
+++ /dev/null
@@ -1,5 +0,0 @@
-from setuptools import setup
-
-
-if __name__ == '__main__':
- setup()