summaryrefslogtreecommitdiffstats
path: root/python/python2-httplib2
diff options
context:
space:
mode:
Diffstat (limited to 'python/python2-httplib2')
-rw-r--r--python/python2-httplib2/README4
-rw-r--r--python/python2-httplib2/python2-httplib2.SlackBuild84
-rw-r--r--python/python2-httplib2/python2-httplib2.info10
-rw-r--r--python/python2-httplib2/slack-desc19
-rw-r--r--python/python2-httplib2/use_system_cacerts.patch37
5 files changed, 154 insertions, 0 deletions
diff --git a/python/python2-httplib2/README b/python/python2-httplib2/README
new file mode 100644
index 0000000000..b831fb5ae7
--- /dev/null
+++ b/python/python2-httplib2/README
@@ -0,0 +1,4 @@
+A comprehensive HTTP client library that supports many features
+left out of other HTTP libraries.
+
+This is the python-2.x version.
diff --git a/python/python2-httplib2/python2-httplib2.SlackBuild b/python/python2-httplib2/python2-httplib2.SlackBuild
new file mode 100644
index 0000000000..fa9c0e28df
--- /dev/null
+++ b/python/python2-httplib2/python2-httplib2.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/bash
+
+# Slackware build script for python3-httplib2
+
+# Copyright 2013-2023 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python2-httplib2
+SRCNAM=httplib2
+VERSION=${VERSION:-0.22.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="CHANGELOG LICENSE README.md"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Use system ca-certificates.crt.
+patch -p1 < $CWD/use_system_cacerts.patch
+
+python2 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-httplib2/python2-httplib2.info b/python/python2-httplib2/python2-httplib2.info
new file mode 100644
index 0000000000..5569748d5b
--- /dev/null
+++ b/python/python2-httplib2/python2-httplib2.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-httplib2"
+VERSION="0.22.0"
+HOMEPAGE="https://github.com/httplib2/httplib2/"
+DOWNLOAD="https://github.com/httplib2/httplib2/archive/v0.22.0/httplib2-0.22.0.tar.gz"
+MD5SUM="e1ea1cd44c908a78112b6007af0f5917"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Matteo Bernardini"
+EMAIL="ponce@slackbuilds.org"
diff --git a/python/python2-httplib2/slack-desc b/python/python2-httplib2/slack-desc
new file mode 100644
index 0000000000..9b5f697fc8
--- /dev/null
+++ b/python/python2-httplib2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-httplib2: python2-httplib2 (python http library)
+python2-httplib2:
+python2-httplib2: A comprehensive HTTP client library that supports many features
+python2-httplib2: left out of other HTTP libraries.
+python2-httplib2:
+python2-httplib2: This is the python-2.x version.
+python2-httplib2:
+python2-httplib2: homepage: https://github.com/httplib2/httplib2/
+python2-httplib2:
+python2-httplib2:
+python2-httplib2:
diff --git a/python/python2-httplib2/use_system_cacerts.patch b/python/python2-httplib2/use_system_cacerts.patch
new file mode 100644
index 0000000000..80523d7178
--- /dev/null
+++ b/python/python2-httplib2/use_system_cacerts.patch
@@ -0,0 +1,37 @@
+--- a/python2/httplib2/certs.py
++++ b/python2/httplib2/certs.py
+@@ -19,9 +19,7 @@ except ImportError:
+ pass
+
+
+-BUILTIN_CA_CERTS = os.path.join(
+- os.path.dirname(os.path.abspath(__file__)), "cacerts.txt"
+-)
++BUILTIN_CA_CERTS = "/etc/ssl/certs/ca-certificates.crt"
+
+
+ def where():
+--- a/python3/httplib2/certs.py
++++ b/python3/httplib2/certs.py
+@@ -19,9 +19,7 @@ except ImportError:
+ pass
+
+
+-BUILTIN_CA_CERTS = os.path.join(
+- os.path.dirname(os.path.abspath(__file__)), "cacerts.txt"
+-)
++BUILTIN_CA_CERTS = "/etc/ssl/certs/ca-certificates.crt"
+
+
+ def where():
+--- a/tests/test_cacerts_from_env.py
++++ b/tests/test_cacerts_from_env.py
+@@ -9,7 +9,7 @@ import tempfile
+ import httplib2
+
+
+-CA_CERTS_BUILTIN = os.path.join(os.path.dirname(httplib2.__file__), "cacerts.txt")
++CA_CERTS_BUILTIN = "/etc/ssl/certs/ca-certificates.crt"
+ CERTIFI_CERTS_FILE = "unittest_certifi_file"
+ CUSTOM_CA_CERTS = "unittest_custom_ca_certs"
+