summaryrefslogtreecommitdiffstats
path: root/python/python3-APScheduler
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-APScheduler')
-rw-r--r--python/python3-APScheduler/README3
-rw-r--r--python/python3-APScheduler/python3-APScheduler.SlackBuild96
-rw-r--r--python/python3-APScheduler/python3-APScheduler.info10
-rw-r--r--python/python3-APScheduler/slack-desc19
4 files changed, 128 insertions, 0 deletions
diff --git a/python/python3-APScheduler/README b/python/python3-APScheduler/README
new file mode 100644
index 0000000000..4693b83f24
--- /dev/null
+++ b/python/python3-APScheduler/README
@@ -0,0 +1,3 @@
+Advanced Python Scheduler (python3-APScheduler) is a Python library
+that lets you schedule your Python code to be executed later, either
+just once or periodically.
diff --git a/python/python3-APScheduler/python3-APScheduler.SlackBuild b/python/python3-APScheduler/python3-APScheduler.SlackBuild
new file mode 100644
index 0000000000..816d082dd1
--- /dev/null
+++ b/python/python3-APScheduler/python3-APScheduler.SlackBuild
@@ -0,0 +1,96 @@
+#!/bin/bash
+
+# Slackware build script for python3-APScheduler
+
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-APScheduler
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-3.10.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst docs/{*.rst,conf.py} $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-APScheduler/python3-APScheduler.info b/python/python3-APScheduler/python3-APScheduler.info
new file mode 100644
index 0000000000..e40b38acca
--- /dev/null
+++ b/python/python3-APScheduler/python3-APScheduler.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-APScheduler"
+VERSION="3.10.4"
+HOMEPAGE="https://pypi.python.org/pypi/APScheduler/"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/a/apscheduler/APScheduler-3.10.4.tar.gz"
+MD5SUM="cf4dd44a52f05e4a06dc104de52e41f5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="tzlocal"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"
diff --git a/python/python3-APScheduler/slack-desc b/python/python3-APScheduler/slack-desc
new file mode 100644
index 0000000000..abca1eff27
--- /dev/null
+++ b/python/python3-APScheduler/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-APScheduler: python3-APScheduler (Advanced Python Scheduler)
+python3-APScheduler:
+python3-APScheduler: Advanced Python Scheduler (APScheduler) is a Python library that lets
+python3-APScheduler: you schedule your Python code to be executed later, either just once
+python3-APScheduler: or periodically.
+python3-APScheduler:
+python3-APScheduler: Homepage: http://pypi.python.org/pypi/APScheduler/
+python3-APScheduler:
+python3-APScheduler:
+python3-APScheduler:
+python3-APScheduler: