summaryrefslogtreecommitdiffstats
path: root/python/python3-Flask-Babel
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-Flask-Babel')
-rw-r--r--python/python3-Flask-Babel/python3-Flask-Babel.SlackBuild40
-rw-r--r--python/python3-Flask-Babel/python3-Flask-Babel.info8
2 files changed, 17 insertions, 31 deletions
diff --git a/python/python3-Flask-Babel/python3-Flask-Babel.SlackBuild b/python/python3-Flask-Babel/python3-Flask-Babel.SlackBuild
index d9502d8ce8..d0a5742b78 100644
--- a/python/python3-Flask-Babel/python3-Flask-Babel.SlackBuild
+++ b/python/python3-Flask-Babel/python3-Flask-Babel.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-Flask-Babel
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,12 +24,14 @@
# 20220512 46and2: Updated version to v2.0.0
# -REQUIRES changed from babel to python3-babel
+# 20230122 46and2: Updated version, change build process, add deps.
+# -source archive filename changed
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-Flask-Babel
-SRCNAM=$(echo $PRGNAM | sed "s/python3-//")
-VERSION=${VERSION:-2.0.0}
+SRCNAM=$(echo ${PRGNAM#python3-*} | sed -e "s/-/_/")
+VERSION=${VERSION:-4.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -42,9 +44,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -54,42 +53,29 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
+rm -rf ${SRCNAM,,}-$VERSION
+tar xvf $CWD/${SRCNAM,,}-$VERSION.tar.gz
+cd ${SRCNAM,,}-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-Flask-Babel/python3-Flask-Babel.info b/python/python3-Flask-Babel/python3-Flask-Babel.info
index 4ee66fee49..1b4911c7e6 100644
--- a/python/python3-Flask-Babel/python3-Flask-Babel.info
+++ b/python/python3-Flask-Babel/python3-Flask-Babel.info
@@ -1,10 +1,10 @@
PRGNAM="python3-Flask-Babel"
-VERSION="2.0.0"
+VERSION="4.0.0"
HOMEPAGE="https://github.com/python-babel/flask-babel"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-babel/Flask-Babel-2.0.0.tar.gz"
-MD5SUM="50d5e92d96ef58787bf85b5a1b0a5567"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-babel/flask_babel-4.0.0.tar.gz"
+MD5SUM="62116080b8d3a446e1f0f07cbaf74dc1"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="Flask python3-babel"
+REQUIRES="python3-poetry-core Flask python3-babel"
MAINTAINER="fourtysixandtwo"
EMAIL="fourtysixandtwo@sliderr.net"