summaryrefslogtreecommitdiffstats
path: root/python/python3-aiofiles/python3-aiofiles.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-aiofiles/python3-aiofiles.SlackBuild')
-rw-r--r--python/python3-aiofiles/python3-aiofiles.SlackBuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/python/python3-aiofiles/python3-aiofiles.SlackBuild b/python/python3-aiofiles/python3-aiofiles.SlackBuild
index 91260448e2..7ca0edefab 100644
--- a/python/python3-aiofiles/python3-aiofiles.SlackBuild
+++ b/python/python3-aiofiles/python3-aiofiles.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-aiofiles
-# Copyright 2022 Steven Voges <Oregon, USA>
+# Copyright 2022-2023 Steven Voges <Oregon, USA>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-aiofiles
SRCNAM=aiofiles
-VERSION=${VERSION:-22.1.0}
+VERSION=${VERSION:-23.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -77,14 +77,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- LICENSE PKG-INFO README.rst \
+ LICENSE NOTICE PKG-INFO README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild