summaryrefslogtreecommitdiffstats
path: root/python/python3-aiorpcX-legacy
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-aiorpcX-legacy')
-rw-r--r--python/python3-aiorpcX-legacy/README10
-rw-r--r--python/python3-aiorpcX-legacy/python3-aiorpcX-legacy.SlackBuild97
-rw-r--r--python/python3-aiorpcX-legacy/python3-aiorpcX-legacy.info10
-rw-r--r--python/python3-aiorpcX-legacy/slack-desc19
4 files changed, 0 insertions, 136 deletions
diff --git a/python/python3-aiorpcX-legacy/README b/python/python3-aiorpcX-legacy/README
deleted file mode 100644
index 3de43160bd..0000000000
--- a/python/python3-aiorpcX-legacy/README
+++ /dev/null
@@ -1,10 +0,0 @@
-aiorpcX is a generic asyncio library implementation of RPC suitable
-for an application that is a client, server or both.
-
-NOTE:
-This is an older version of the program, kept here for compatibility
-with Electrum.
-
-IMPORTANT:
-This package conflicts with python3-aiorpcX, python3-aiorpcX-legacy
-and python3-aiorpcX cannot both be installed at the same time.
diff --git a/python/python3-aiorpcX-legacy/python3-aiorpcX-legacy.SlackBuild b/python/python3-aiorpcX-legacy/python3-aiorpcX-legacy.SlackBuild
deleted file mode 100644
index b6eceaba7e..0000000000
--- a/python/python3-aiorpcX-legacy/python3-aiorpcX-legacy.SlackBuild
+++ /dev/null
@@ -1,97 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python3-aiorpcX-legacy
-# Copyright 2019-2021 Isaac Yu <isaacyu1@isaacyu1.com>
-# Copyright 2021 nomnombtc <nomnombtc@arcor.de>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python3-aiorpcX-legacy
-VERSION=${VERSION:-0.18.7}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-SRCNAM=aiorpcX
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst docs/ LICENCE $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-aiorpcX-legacy/python3-aiorpcX-legacy.info b/python/python3-aiorpcX-legacy/python3-aiorpcX-legacy.info
deleted file mode 100644
index e4aca61d3c..0000000000
--- a/python/python3-aiorpcX-legacy/python3-aiorpcX-legacy.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-aiorpcX-legacy"
-VERSION="0.18.7"
-HOMEPAGE="https://aiorpcx.readthedocs.io/en/stable/"
-DOWNLOAD="https://github.com/kyuupichan/aiorpcX/archive/0.18.7/aiorpcX-0.18.7.tar.gz"
-MD5SUM="8349fdc8ad6bfb37174ae24b444d8485"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3-attrs"
-MAINTAINER="nomnombtc"
-EMAIL="nomnombtc@arcor.de"
diff --git a/python/python3-aiorpcX-legacy/slack-desc b/python/python3-aiorpcX-legacy/slack-desc
deleted file mode 100644
index 607ffe6a83..0000000000
--- a/python/python3-aiorpcX-legacy/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-aiorpcX-legacy: python3-aiorpcX-legacy (Generic async RPC implementation)
-python3-aiorpcX-legacy:
-python3-aiorpcX-legacy: aiorpcX is a generic asyncio library implementation of RPC suitable
-python3-aiorpcX-legacy: for an application that is a client, server or both.
-python3-aiorpcX-legacy:
-python3-aiorpcX-legacy: https://aiorpcx.readthedocs.io/en/stable/
-python3-aiorpcX-legacy:
-python3-aiorpcX-legacy:
-python3-aiorpcX-legacy:
-python3-aiorpcX-legacy:
-python3-aiorpcX-legacy: