summaryrefslogtreecommitdiffstats
path: root/python/python3-dulwich
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-dulwich')
-rw-r--r--python/python3-dulwich/python3-dulwich.SlackBuild9
-rw-r--r--python/python3-dulwich/python3-dulwich.info8
2 files changed, 8 insertions, 9 deletions
diff --git a/python/python3-dulwich/python3-dulwich.SlackBuild b/python/python3-dulwich/python3-dulwich.SlackBuild
index f4d40c7c61..45a80b20ec 100644
--- a/python/python3-dulwich/python3-dulwich.SlackBuild
+++ b/python/python3-dulwich/python3-dulwich.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-dulwich
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-0.20.42}
+VERSION=${VERSION:-0.22.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -67,13 +64,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS *.md *.rst COPYING NEWS $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS *.rst COPYING NEWS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-dulwich/python3-dulwich.info b/python/python3-dulwich/python3-dulwich.info
index 4da975fc53..9ecc757a3a 100644
--- a/python/python3-dulwich/python3-dulwich.info
+++ b/python/python3-dulwich/python3-dulwich.info
@@ -1,10 +1,10 @@
PRGNAM="python3-dulwich"
-VERSION="0.20.42"
+VERSION="0.22.1"
HOMEPAGE="https://www.dulwich.io/"
-DOWNLOAD="https://pypi.python.org/packages/source/d/dulwich/dulwich-0.20.42.tar.gz"
-MD5SUM="4fa7821a13c51d7f5b9a5ead5fec4be1"
+DOWNLOAD="https://pypi.python.org/packages/source/d/dulwich/dulwich-0.22.1.tar.gz"
+MD5SUM="08e441d9f3c978a89ce682bfcc101dda"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-setuptools-rust-opt"
MAINTAINER="Yth - Arnaud"
EMAIL="yth@ythogtha.org"