summaryrefslogtreecommitdiffstats
path: root/python/python3-eventlet
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-eventlet')
-rw-r--r--python/python3-eventlet/README13
-rw-r--r--python/python3-eventlet/python3-eventlet.SlackBuild98
-rw-r--r--python/python3-eventlet/python3-eventlet.info10
-rw-r--r--python/python3-eventlet/slack-desc19
4 files changed, 140 insertions, 0 deletions
diff --git a/python/python3-eventlet/README b/python/python3-eventlet/README
new file mode 100644
index 0000000000..6037c28648
--- /dev/null
+++ b/python/python3-eventlet/README
@@ -0,0 +1,13 @@
+Eventlet is a concurrent networking library for Python that allows
+you to change how you run your code, not how you write it.
+
+It uses epoll or libevent for highly scalable non-blocking I/O.
+Coroutines ensure that the developer uses a blocking style of
+programming that is similar to threading, but provide the benefits of
+non-blocking I/O. The event dispatch is implicit, which means you
+can easily use Eventlet from the Python interpreter, or as a small
+part of a larger application.
+
+It's easy to get started using Eventlet, and easy to convert existing
+applications to use it. Start off by looking at the examples,
+common design patterns, and the list of basic API primitives.
diff --git a/python/python3-eventlet/python3-eventlet.SlackBuild b/python/python3-eventlet/python3-eventlet.SlackBuild
new file mode 100644
index 0000000000..461d85d31c
--- /dev/null
+++ b/python/python3-eventlet/python3-eventlet.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/bash
+
+# Slackware build script for python3-eventlet
+
+# Copyright 2023, Nikos Giotis, Athens, GR
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-eventlet
+SRCNAM=eventlet
+VERSION=${VERSION:-0.33.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-eventlet/python3-eventlet.info b/python/python3-eventlet/python3-eventlet.info
new file mode 100644
index 0000000000..9b73075890
--- /dev/null
+++ b/python/python3-eventlet/python3-eventlet.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-eventlet"
+VERSION="0.33.3"
+HOMEPAGE="http://eventlet.net/"
+DOWNLOAD="https://files.pythonhosted.org/packages/81/0c/5e0bcf715a2bae9169c77bfdcbc460a4aeeb0bb1067cf8071cf14d7d1b39/eventlet-0.33.3.tar.gz"
+MD5SUM="3a488f65bc4ebeec8141a2a9fbe77955"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="greenlet"
+MAINTAINER="Nikos Giotis"
+EMAIL="nikos.giotis@gmail.com"
diff --git a/python/python3-eventlet/slack-desc b/python/python3-eventlet/slack-desc
new file mode 100644
index 0000000000..ae0cf8bfe2
--- /dev/null
+++ b/python/python3-eventlet/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-eventlet: python3-eventlet (a concurrent networking library for Python)
+python3-eventlet:
+python3-eventlet: Eventlet is a concurrent networking library for Python that allows
+python3-eventlet: you to change how you run your code, not how you write it.
+python3-eventlet:
+python3-eventlet:
+python3-eventlet:
+python3-eventlet:
+python3-eventlet:
+python3-eventlet:
+python3-eventlet: