summaryrefslogtreecommitdiffstats
path: root/python/python3-h5py
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-h5py')
-rw-r--r--python/python3-h5py/python3-h5py.SlackBuild18
-rw-r--r--python/python3-h5py/python3-h5py.info10
2 files changed, 12 insertions, 16 deletions
diff --git a/python/python3-h5py/python3-h5py.SlackBuild b/python/python3-h5py/python3-h5py.SlackBuild
index 20e1bbd1ac..746daebfa3 100644
--- a/python/python3-h5py/python3-h5py.SlackBuild
+++ b/python/python3-h5py/python3-h5py.SlackBuild
@@ -2,7 +2,9 @@
# Slackware build script for python3-h5py
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2024 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023 Petar Petrov slackalaxy@gmail.com
+# Copyright 2022-2023 Isaac Yu
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-h5py
-VERSION=${VERSION:-3.7.0}
+VERSION=${VERSION:-3.11.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -53,16 +52,12 @@ PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
- SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
@@ -85,13 +80,14 @@ find -L . \
sed -i "s/settings\\['runtime_library_dirs'\\] = settings\\['library_dirs'\\]/pass/" setup_build.py
H5PY_SYSTEM_LZF=1 python3 setup.py build
-python3 setup.py install --root=$PKG --skip-build --optimize=1
+python3 setup.py install --root=$PKG --skip-build
+cp -a h5py/{_hl,tests,*.py} $PKG/usr/lib${LIBDIRSUFFIX}/python3.9/site-packages/h5py
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-h5py/python3-h5py.info b/python/python3-h5py/python3-h5py.info
index d14e849a52..b61bfd5439 100644
--- a/python/python3-h5py/python3-h5py.info
+++ b/python/python3-h5py/python3-h5py.info
@@ -1,10 +1,10 @@
PRGNAM="python3-h5py"
-VERSION="3.7.0"
+VERSION="3.11.0"
HOMEPAGE="https://www.h5py.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/h/h5py/h5py-3.7.0.tar.gz"
-MD5SUM="acb43ba2b0b853005af71eccfc456676"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/h/h5py/h5py-3.11.0.tar.gz"
+MD5SUM="710eb17c1bae08a3ba684889b1108fdb"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="hdf5 liblzf numpy3 python3-pkgconfig"
+REQUIRES="hdf5 liblzf python3-numpy python3-pkgconfig"
MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
+EMAIL="isaacyu@protonmail.com"