summaryrefslogtreecommitdiffstats
path: root/python/python3-pandas
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-pandas')
-rw-r--r--python/python3-pandas/README4
-rw-r--r--python/python3-pandas/python3-pandas.SlackBuild39
-rw-r--r--python/python3-pandas/python3-pandas.info12
3 files changed, 26 insertions, 29 deletions
diff --git a/python/python3-pandas/README b/python/python3-pandas/README
index 52bcdcc388..ca985dbc7a 100644
--- a/python/python3-pandas/README
+++ b/python/python3-pandas/README
@@ -3,5 +3,5 @@ BSD-licensed library providing high-performance, easy-to-use data
structures and data analysis tools for the Python programming
language.
-python3-pandas 1.4.2 is the last possible version for Slackware 15.0.
-Newer versions require a newer Cython (as a build dependency).
+NOTE: Unable to support newer versions than 2.1.4 due to requiring a
+newer Cython than included in Slackware (needs 3.0.5).
diff --git a/python/python3-pandas/python3-pandas.SlackBuild b/python/python3-pandas/python3-pandas.SlackBuild
index 77458abb29..daa7810213 100644
--- a/python/python3-pandas/python3-pandas.SlackBuild
+++ b/python/python3-pandas/python3-pandas.SlackBuild
@@ -3,7 +3,8 @@
# Slackware build script for python3-pandas
# Copyright 2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023-2024 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pandas
SRCNAM=pandas
-VERSION=${VERSION:-1.4.2}
+VERSION=${VERSION:-2.1.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -52,20 +50,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -81,14 +65,27 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# remove requirement
+sed -i '/oldest-supported-numpy/d' pyproject.toml
+
+# convert to minimum req'd instead of pinned
+sed -i 's/meson-python==/meson-python>=/' pyproject.toml
+sed -i 's/meson==/meson>=/' pyproject.toml
+
+# needs newer meson
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+# cannot build sdist, specify just wheel
+python3 -m build --wheel --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- LICENSE PKG-INFO README.md RELEASE.md \
+ AUTHORS.md LICENSE PKG-INFO README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/python3-pandas/python3-pandas.info b/python/python3-pandas/python3-pandas.info
index 74e278ad2f..45852698ca 100644
--- a/python/python3-pandas/python3-pandas.info
+++ b/python/python3-pandas/python3-pandas.info
@@ -1,10 +1,10 @@
PRGNAM="python3-pandas"
-VERSION="1.4.2"
+VERSION="2.1.4"
HOMEPAGE="https://pandas.pydata.org"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pandas/pandas-1.4.2.tar.gz"
-MD5SUM="6e007c8e950c280f7ac31cfaec8ab361"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pandas/pandas-2.1.4.tar.gz"
+MD5SUM="e4b598d1e0aac2a3407ed32added3f62"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="numpy3 python3-dateutil pytz"
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
+REQUIRES="python3-numpy python3-dateutil python3-pytz tzdata python3-versioneer"
+MAINTAINER="Jeremy Hansen"
+EMAIL="jebrhansen+SBo@gmail.com"