summaryrefslogtreecommitdiffstats
path: root/python/python3-pgpy
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-pgpy')
-rw-r--r--python/python3-pgpy/README11
-rw-r--r--python/python3-pgpy/python3-pgpy.SlackBuild100
-rw-r--r--python/python3-pgpy/python3-pgpy.info10
-rw-r--r--python/python3-pgpy/slack-desc19
4 files changed, 140 insertions, 0 deletions
diff --git a/python/python3-pgpy/README b/python/python3-pgpy/README
new file mode 100644
index 0000000000..152bd13d45
--- /dev/null
+++ b/python/python3-pgpy/README
@@ -0,0 +1,11 @@
+PGPy: Pretty Good Privacy for Python
+
+PGPy is a Python library for implementing Pretty Good Privacy into
+Python programs, conforming to the OpenPGP specification per RFC 4880.
+
+
+Currently, PGPy can load keys and signatures of all kinds in both
+ASCII armored and binary formats.
+
+It can create and verify RSA, DSA, and ECDSA signatures, at the
+moment. It can also encrypt and decrypt messages using RSA and ECDH.
diff --git a/python/python3-pgpy/python3-pgpy.SlackBuild b/python/python3-pgpy/python3-pgpy.SlackBuild
new file mode 100644
index 0000000000..def9743d8d
--- /dev/null
+++ b/python/python3-pgpy/python3-pgpy.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/bash
+
+# Slackware build script for python3-pgpy
+
+# Copyright 2023, Lockywolf
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-pgpy
+TARNAM=PGPy
+VERSION=${VERSION:-0.6.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $TARNAM-$VERSION
+tar xvf $CWD/$TARNAM-$VERSION.tar.gz
+cd $TARNAM-$VERSION
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
+
+python3 setup.py install --root=$PKG
+
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+LICENSE README.rst docs/ \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-pgpy/python3-pgpy.info b/python/python3-pgpy/python3-pgpy.info
new file mode 100644
index 0000000000..6de7606e3d
--- /dev/null
+++ b/python/python3-pgpy/python3-pgpy.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-pgpy"
+VERSION="0.6.0"
+HOMEPAGE="https://github.com/SecurityInnovation/PGPy"
+DOWNLOAD="https://github.com/SecurityInnovation/PGPy/releases/download/v0.6.0/PGPy-0.6.0.tar.gz"
+MD5SUM="58e648e27e4f56d66fea01ef64e344f7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.python3-pgpy_2023-09-22@lockywolf.net"
diff --git a/python/python3-pgpy/slack-desc b/python/python3-pgpy/slack-desc
new file mode 100644
index 0000000000..50ff40dcc9
--- /dev/null
+++ b/python/python3-pgpy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-pgpy: python3-pgpy (PGP for Python3)
+python3-pgpy:
+python3-pgpy: PGPy is a Python library for implementing Pretty Good Privacy into
+python3-pgpy: Python programs, conforming to the OpenPGP specification per RFC
+python3-pgpy: 4880.
+python3-pgpy:
+python3-pgpy:
+python3-pgpy:
+python3-pgpy:
+python3-pgpy:
+python3-pgpy: