summaryrefslogtreecommitdiffstats
path: root/python/python3-pybcj
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-pybcj')
-rw-r--r--python/python3-pybcj/README13
-rw-r--r--python/python3-pybcj/python3-pybcj.SlackBuild103
-rw-r--r--python/python3-pybcj/python3-pybcj.info10
-rw-r--r--python/python3-pybcj/slack-desc19
4 files changed, 145 insertions, 0 deletions
diff --git a/python/python3-pybcj/README b/python/python3-pybcj/README
new file mode 100644
index 0000000000..6979f97d89
--- /dev/null
+++ b/python/python3-pybcj/README
@@ -0,0 +1,13 @@
+pybcj is a bcj filter library
+
+In data compression, BCJ, short for Branch-Call-Jump, refers to a
+technique that improves the compression of machine code of executable
+binaries by replacing relative branch addresses with absolute ones. This
+allows a LZMA compressor to identify duplicate targets and archive
+higher compression rate.
+
+BCJ is used in 7-zip compression utility as default filter for
+executable binaries.
+
+pybcj is a python bindings with BCJ implementation by C language. The C
+codes are derived from p7zip, portable 7-zip implementation.
diff --git a/python/python3-pybcj/python3-pybcj.SlackBuild b/python/python3-pybcj/python3-pybcj.SlackBuild
new file mode 100644
index 0000000000..d7a9c0f027
--- /dev/null
+++ b/python/python3-pybcj/python3-pybcj.SlackBuild
@@ -0,0 +1,103 @@
+#!/bin/bash
+
+# Slackware build script for python3-pybcj
+
+# Copyright 2023, Lockywolf
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-pybcj
+TARNAM=pybcj
+VERSION=${VERSION:-1.0.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+
+rm -rf $TARNAM-$VERSION
+tar xvf $CWD/$TARNAM-$VERSION.tar.gz
+cd $TARNAM-$VERSION
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ Changelog.rst LICENSE README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-pybcj/python3-pybcj.info b/python/python3-pybcj/python3-pybcj.info
new file mode 100644
index 0000000000..042607c3e9
--- /dev/null
+++ b/python/python3-pybcj/python3-pybcj.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-pybcj"
+VERSION="1.0.2"
+HOMEPAGE="https://pypi.org/project/pybcj/"
+DOWNLOAD="https://files.pythonhosted.org/packages/37/d2/22e808b9d25ce3b43f5c8a9e22d873d403485ba55d84a4d6d5d044881762/pybcj-1.0.2.tar.gz"
+MD5SUM="efc9c68c07f14d4dcb01edb9cbf66335"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-setuptools-scm-opt"
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.python3-pybcj_2023-12-04@lockywolf.net"
diff --git a/python/python3-pybcj/slack-desc b/python/python3-pybcj/slack-desc
new file mode 100644
index 0000000000..f4538e6ffc
--- /dev/null
+++ b/python/python3-pybcj/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-pybcj: python3-pybcj (bcj filter library)
+python3-pybcj:
+python3-pybcj: pybcj is a python bindings with BCJ implementation by C language.
+python3-pybcj: The C codes are derived from p7zip, portable 7-zip implementation.
+python3-pybcj:
+python3-pybcj:
+python3-pybcj:
+python3-pybcj:
+python3-pybcj:
+python3-pybcj:
+python3-pybcj: