summaryrefslogtreecommitdiffstats
path: root/python/python3-pytest
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-pytest')
-rw-r--r--python/python3-pytest/README2
-rw-r--r--python/python3-pytest/python3-pytest.SlackBuild29
-rw-r--r--python/python3-pytest/python3-pytest.info12
3 files changed, 16 insertions, 27 deletions
diff --git a/python/python3-pytest/README b/python/python3-pytest/README
index 67590abb9b..af8dfd5112 100644
--- a/python/python3-pytest/README
+++ b/python/python3-pytest/README
@@ -7,4 +7,4 @@ IMPORTANT: The scripts py.test and pytest are renamed to py.test3
and pytest3 respectively to avoid conflicts with the pytest installed
with python.
-NOTE: py, pluggy and iniconfig have automatic python3 support.
+This is the Python 3 build of pytest.
diff --git a/python/python3-pytest/python3-pytest.SlackBuild b/python/python3-pytest/python3-pytest.SlackBuild
index d4b78e1b2c..a630532749 100644
--- a/python/python3-pytest/python3-pytest.SlackBuild
+++ b/python/python3-pytest/python3-pytest.SlackBuild
@@ -3,7 +3,8 @@
# Slackware build script for python3-pytest
# Copyright 2018 Serban Udrea <S.Udrea@gsi.de>
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2023 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023-2024 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
# Based on the pytest SlackBuild by Dimitris Zlatanidis Orestiada, Greece
#
@@ -28,7 +29,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pytest
SRCNAM=pytest
-VERSION=${VERSION:-7.1.3}
+VERSION=${VERSION:-8.3.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -53,20 +51,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -82,7 +66,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# Use newer setuptools
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
mv $PKG/usr/bin/py.test $PKG/usr/bin/py.test3
mv $PKG/usr/bin/pytest $PKG/usr/bin/pytest3
diff --git a/python/python3-pytest/python3-pytest.info b/python/python3-pytest/python3-pytest.info
index dc3de0811e..f6b48daf4c 100644
--- a/python/python3-pytest/python3-pytest.info
+++ b/python/python3-pytest/python3-pytest.info
@@ -1,10 +1,10 @@
PRGNAM="python3-pytest"
-VERSION="7.1.3"
+VERSION="8.3.3"
HOMEPAGE="http://pytest.org"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pytest/pytest-7.1.3.tar.gz"
-MD5SUM="c4de3e192e5bb4b39deada36cc2f393a"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pytest/pytest-8.3.3.tar.gz"
+MD5SUM="71466867181a5a7aefdb298b7146bcad"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="py python3-attrs python3-pluggy iniconfig"
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
+REQUIRES="python3-iniconfig python3-exceptiongroup python3-setuptools-opt"
+MAINTAINER="Jeremy Hansen"
+EMAIL="jebrhansen+SBo@gmail.com"