summaryrefslogtreecommitdiffstats
path: root/python/python3-pyzmq
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-pyzmq')
-rw-r--r--python/python3-pyzmq/python3-pyzmq.SlackBuild8
-rw-r--r--python/python3-pyzmq/python3-pyzmq.info8
2 files changed, 9 insertions, 7 deletions
diff --git a/python/python3-pyzmq/python3-pyzmq.SlackBuild b/python/python3-pyzmq/python3-pyzmq.SlackBuild
index 9c839c05c5..f20c617a7d 100644
--- a/python/python3-pyzmq/python3-pyzmq.SlackBuild
+++ b/python/python3-pyzmq/python3-pyzmq.SlackBuild
@@ -3,7 +3,7 @@
# SlackBuild script for python3-pyzmq
# Copyright 2013 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2016-2022 Christoph Willing Brisbane, Australia
+# Copyright 2016-2023 Christoph Willing Brisbane, Australia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pyzmq
SRCNAM=pyzmq
-VERSION=${VERSION:-23.1.0}
+VERSION=${VERSION:-25.1.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -78,13 +78,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS.md COPYING.BSD COPYING.LESSER README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS.md LICENSE.BSD LICENSE.LESSER README.md SECURITY.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-pyzmq/python3-pyzmq.info b/python/python3-pyzmq/python3-pyzmq.info
index 953dff36bf..d765c2d8af 100644
--- a/python/python3-pyzmq/python3-pyzmq.info
+++ b/python/python3-pyzmq/python3-pyzmq.info
@@ -1,10 +1,10 @@
PRGNAM="python3-pyzmq"
-VERSION="23.1.0"
+VERSION="25.1.2"
HOMEPAGE="https://github.com/zeromq/pyzmq"
-DOWNLOAD="https://github.com/zeromq/pyzmq/archive/v23.1.0/pyzmq-23.1.0.tar.gz"
-MD5SUM="704bed5212fe3668aa38ef248664574c"
+DOWNLOAD="https://github.com/zeromq/pyzmq/archive/v25.1.2/pyzmq-25.1.2.tar.gz"
+MD5SUM="f4811db6518af8b9f96dd84642490f45"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="zeromq"
+REQUIRES="python3-setuptools-opt zeromq"
MAINTAINER="Christoph Willing"
EMAIL="chris.willing@linux.com"