summaryrefslogtreecommitdiffstats
path: root/python/python3-soupsieve
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-soupsieve')
-rw-r--r--python/python3-soupsieve/README3
-rw-r--r--python/python3-soupsieve/python3-soupsieve.SlackBuild33
-rw-r--r--python/python3-soupsieve/python3-soupsieve.info12
3 files changed, 18 insertions, 30 deletions
diff --git a/python/python3-soupsieve/README b/python/python3-soupsieve/README
index 907b6b44af..a294930611 100644
--- a/python/python3-soupsieve/README
+++ b/python/python3-soupsieve/README
@@ -4,3 +4,6 @@ filtering using modern CSS selectors.
Soup Sieve >= 2.0.0 has dropped Python 2 support. The
python-soupsieve SlackBuild is available at version 1.9.6.
+
+python3-build, python3-hatchling, python3-installer are
+dependencies required for the build only.
diff --git a/python/python3-soupsieve/python3-soupsieve.SlackBuild b/python/python3-soupsieve/python3-soupsieve.SlackBuild
index 2fa1570943..24d49bea9c 100644
--- a/python/python3-soupsieve/python3-soupsieve.SlackBuild
+++ b/python/python3-soupsieve/python3-soupsieve.SlackBuild
@@ -2,7 +2,8 @@
# Slackware build script for python3-soupsieve
-# Copyright 2020-2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2023-2024 Giancarlo Dessi, Cagliari, IT, <slack@giand.it>
+# Copyright 2020-2022 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,14 +23,11 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# 20220415 bkw: Modified by SlackBuilds.org, BUILD=2:
-# - clean up the doc dir.
-
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-soupsieve
-VERSION=${VERSION:-2.3.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.6}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -52,20 +50,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -81,14 +65,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-# 20220415 bkw: since we can't build the HTML docs from the markdown
-# source (we lack the tools), just put the markdown files in the doc dir.
-# they're pretty readable as-is.
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a *.md docs/src/markdown/{*.md,selectors,about} $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/python3-soupsieve/python3-soupsieve.info b/python/python3-soupsieve/python3-soupsieve.info
index 0f61f3cbe6..1fb8593c49 100644
--- a/python/python3-soupsieve/python3-soupsieve.info
+++ b/python/python3-soupsieve/python3-soupsieve.info
@@ -1,10 +1,10 @@
PRGNAM="python3-soupsieve"
-VERSION="2.3.1"
+VERSION="2.6"
HOMEPAGE="https://github.com/facelessuser/soupsieve"
-DOWNLOAD="https://github.com/facelessuser/soupsieve/archive/2.3.1/soupsieve-2.3.1.tar.gz"
-MD5SUM="fa73aed77dc311dbe10f261a65d86c8d"
+DOWNLOAD="https://github.com/facelessuser/soupsieve/archive/2.6/soupsieve-2.6.tar.gz"
+MD5SUM="a3dcdd1a5472c9404110fc07dfc64415"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
+REQUIRES="python3-hatchling"
+MAINTAINER="Giancarlo Dessi"
+EMAIL="slack@giand.it"