summaryrefslogtreecommitdiffstats
path: root/python/python3-zodbpickle
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-zodbpickle')
-rw-r--r--python/python3-zodbpickle/README13
-rw-r--r--python/python3-zodbpickle/python3-zodbpickle.SlackBuild74
-rw-r--r--python/python3-zodbpickle/python3-zodbpickle.info10
-rw-r--r--python/python3-zodbpickle/slack-desc19
4 files changed, 116 insertions, 0 deletions
diff --git a/python/python3-zodbpickle/README b/python/python3-zodbpickle/README
new file mode 100644
index 0000000000..e3931221ea
--- /dev/null
+++ b/python/python3-zodbpickle/README
@@ -0,0 +1,13 @@
+zodbpickle: Fork of Python 3 pickle module.
+
+This package presents a uniform pickling interface for ZODB:
+
+- Under Python2, this package forks both Python 2.7's ``pickle`` and
+ ``cPickle`` modules, adding support for the ``protocol 3`` opcodes.
+ It also provides a new subclass of ``bytes``, ``zodbpickle.binary``,
+ which Python2 applications can use to pickle binary values such that
+ they will be unpickled as ``bytes`` under Py3k.
+
+- Under Py3k, this package forks the ``pickle`` module (and the
+ supporting C extension) from both Python 3.2 and Python 3.3.
+ The fork add support for the ``noload`` operations used by ZODB.
diff --git a/python/python3-zodbpickle/python3-zodbpickle.SlackBuild b/python/python3-zodbpickle/python3-zodbpickle.SlackBuild
new file mode 100644
index 0000000000..0142ec13b6
--- /dev/null
+++ b/python/python3-zodbpickle/python3-zodbpickle.SlackBuild
@@ -0,0 +1,74 @@
+#!/bin/bash
+
+# Slackware build script for python3-zodbpickle
+
+# Copyright 2023 Yth | Pont-en-Royans, France | yth@ythogtha.org
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-zodbpickle
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-4.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z*
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) -exec chmod 755 {} \; -o \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a [A-Z][A-Z]* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-zodbpickle/python3-zodbpickle.info b/python/python3-zodbpickle/python3-zodbpickle.info
new file mode 100644
index 0000000000..9a2218b2f5
--- /dev/null
+++ b/python/python3-zodbpickle/python3-zodbpickle.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-zodbpickle"
+VERSION="4.0"
+HOMEPAGE="https://github.com/zopefoundation/zodbpickle"
+DOWNLOAD="https://pypi.python.org/packages/source/z/zodbpickle/zodbpickle-4.0.tar.gz"
+MD5SUM="87cbb33f1363b38c8930be18a2643f8c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-zodbpickle/slack-desc b/python/python3-zodbpickle/slack-desc
new file mode 100644
index 0000000000..8c499bf84c
--- /dev/null
+++ b/python/python3-zodbpickle/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-zodbpickle: python3-zodbpickle (Fork of Python 3 pickle module)
+python3-zodbpickle:
+python3-zodbpickle: This package presents a uniform pickling interface for ZODB:
+python3-zodbpickle: this package forks the ``pickle`` module (and the supporting
+python3-zodbpickle: C extension) from both Python 3.2 and Python 3.3.
+python3-zodbpickle: The fork add support for the ``noload`` operations used by ZODB.
+python3-zodbpickle:
+python3-zodbpickle:
+python3-zodbpickle:
+python3-zodbpickle:
+python3-zodbpickle: