summaryrefslogtreecommitdiffstats
path: root/python/pyudev/pyudev.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyudev/pyudev.SlackBuild')
-rw-r--r--python/pyudev/pyudev.SlackBuild20
1 files changed, 5 insertions, 15 deletions
diff --git a/python/pyudev/pyudev.SlackBuild b/python/pyudev/pyudev.SlackBuild
index 156dfdff05..b177b59cb6 100644
--- a/python/pyudev/pyudev.SlackBuild
+++ b/python/pyudev/pyudev.SlackBuild
@@ -1,8 +1,9 @@
#!/bin/bash
+
# Slackware build script for pyudev
# Copyright 2012 Jon Ware <jon@waremail.net>
-# Copyright 2018-2020 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2018-2023 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pyudev
-VERSION=${VERSION:-0.22.0}
+VERSION=${VERSION:-0.24.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -79,18 +77,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Python 2 support (Default)
-if $(python -c 'import six' 2>/dev/null); then
- python setup.py install --root=$PKG
-fi
-
-# Python 3 support
-if $(python3 -c 'import six' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-install -m 0644 *.txt *.rst COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.rst COPYING README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install