summaryrefslogtreecommitdiffstats
path: root/python/snowballstemmer/snowballstemmer.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/snowballstemmer/snowballstemmer.SlackBuild')
-rw-r--r--python/snowballstemmer/snowballstemmer.SlackBuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/python/snowballstemmer/snowballstemmer.SlackBuild b/python/snowballstemmer/snowballstemmer.SlackBuild
index 00f83e6019..805761b599 100644
--- a/python/snowballstemmer/snowballstemmer.SlackBuild
+++ b/python/snowballstemmer/snowballstemmer.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for snowballstemmer
-# Copyright 2017,2018 Nikos Giotis <nikos.giotis@gmail.com>, Athens, GR
+# Copyright 2017-2023, Nikos Giotis, Athens, GR
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=snowballstemmer
-VERSION=${VERSION:-1.2.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.2.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,16 +79,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Build
python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install