summaryrefslogtreecommitdiffstats
path: root/python/sphinxcontrib-htmlhelp
diff options
context:
space:
mode:
Diffstat (limited to 'python/sphinxcontrib-htmlhelp')
-rw-r--r--python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp.SlackBuild38
-rw-r--r--python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp.info12
2 files changed, 19 insertions, 31 deletions
diff --git a/python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp.SlackBuild b/python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp.SlackBuild
index 56bf2b900f..0e1453ad64 100644
--- a/python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp.SlackBuild
+++ b/python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for sphinxcontrib-htmlhelp
+# Copyright 2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2019-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
@@ -22,10 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20240101 46and2: Updated version, new maintainer.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sphinxcontrib-htmlhelp
-VERSION=${VERSION:-2.0.0}
+SRCNAM=sphinxcontrib_htmlhelp
+VERSION=${VERSION:-2.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,43 +51,30 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- CHANGES LICENSE README.rst \
+ CHANGES.rst LICENCE.rst README.rst \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp.info b/python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp.info
index 414ef972f0..56bd5d98c4 100644
--- a/python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp.info
+++ b/python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp.info
@@ -1,10 +1,10 @@
PRGNAM="sphinxcontrib-htmlhelp"
-VERSION="2.0.0"
+VERSION="2.1.0"
HOMEPAGE="https://github.com/sphinx-doc/sphinxcontrib-htmlhelp"
-DOWNLOAD="https://files.pythonhosted.org/packages/eb/85/93464ac9bd43d248e7c74573d58a791d48c475230bcf000df2b2700b9027/sphinxcontrib-htmlhelp-2.0.0.tar.gz"
-MD5SUM="70765b55395a3c20233631802902c840"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/s/sphinxcontrib-htmlhelp/sphinxcontrib_htmlhelp-2.1.0.tar.gz"
+MD5SUM="1326f55f6bea49ab6a846c0088bc369e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
+REQUIRES="python3-build"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"