summaryrefslogtreecommitdiffstats
path: root/python/sphinxcontrib-jsmath
diff options
context:
space:
mode:
Diffstat (limited to 'python/sphinxcontrib-jsmath')
-rw-r--r--python/sphinxcontrib-jsmath/sphinxcontrib-jsmath.SlackBuild24
-rw-r--r--python/sphinxcontrib-jsmath/sphinxcontrib-jsmath.info4
2 files changed, 7 insertions, 21 deletions
diff --git a/python/sphinxcontrib-jsmath/sphinxcontrib-jsmath.SlackBuild b/python/sphinxcontrib-jsmath/sphinxcontrib-jsmath.SlackBuild
index e00f289d51..710a2cf4cc 100644
--- a/python/sphinxcontrib-jsmath/sphinxcontrib-jsmath.SlackBuild
+++ b/python/sphinxcontrib-jsmath/sphinxcontrib-jsmath.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for sphinxcontrib-jsmath
+# Copyright 2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
@@ -22,6 +23,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20240101 46and2: New maintainer.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sphinxcontrib-jsmath
@@ -38,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,20 +50,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -75,9 +61,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
diff --git a/python/sphinxcontrib-jsmath/sphinxcontrib-jsmath.info b/python/sphinxcontrib-jsmath/sphinxcontrib-jsmath.info
index f970e42f1c..a37ebf4e7c 100644
--- a/python/sphinxcontrib-jsmath/sphinxcontrib-jsmath.info
+++ b/python/sphinxcontrib-jsmath/sphinxcontrib-jsmath.info
@@ -6,5 +6,5 @@ MD5SUM="e45179f0a3608b6766862e0f34c23b62"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"