summaryrefslogtreecommitdiffstats
path: root/python/sphinxcontrib-qthelp
diff options
context:
space:
mode:
Diffstat (limited to 'python/sphinxcontrib-qthelp')
-rw-r--r--python/sphinxcontrib-qthelp/sphinxcontrib-qthelp.SlackBuild38
-rw-r--r--python/sphinxcontrib-qthelp/sphinxcontrib-qthelp.info12
2 files changed, 19 insertions, 31 deletions
diff --git a/python/sphinxcontrib-qthelp/sphinxcontrib-qthelp.SlackBuild b/python/sphinxcontrib-qthelp/sphinxcontrib-qthelp.SlackBuild
index e958055f07..d28383379a 100644
--- a/python/sphinxcontrib-qthelp/sphinxcontrib-qthelp.SlackBuild
+++ b/python/sphinxcontrib-qthelp/sphinxcontrib-qthelp.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for sphinxcontrib-qthelp
+# Copyright 2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2019-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
@@ -22,10 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20240101 46and2: Updated version, new maintainer.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sphinxcontrib-qthelp
-VERSION=${VERSION:-1.0.3}
+SRCNAM=sphinxcontrib_qthelp
+VERSION=${VERSION:-2.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,43 +51,30 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- CHANGES LICENSE README.rst \
+ CHANGES.rst LICENCE.rst README.rst \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/sphinxcontrib-qthelp/sphinxcontrib-qthelp.info b/python/sphinxcontrib-qthelp/sphinxcontrib-qthelp.info
index a77c661219..a193b74ca0 100644
--- a/python/sphinxcontrib-qthelp/sphinxcontrib-qthelp.info
+++ b/python/sphinxcontrib-qthelp/sphinxcontrib-qthelp.info
@@ -1,10 +1,10 @@
PRGNAM="sphinxcontrib-qthelp"
-VERSION="1.0.3"
+VERSION="2.0.0"
HOMEPAGE="https://github.com/sphinx-doc/sphinxcontrib-qthelp"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/s/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3.tar.gz"
-MD5SUM="93216721f3e154cce12d1e9c3307b415"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/s/sphinxcontrib-qthelp/sphinxcontrib_qthelp-2.0.0.tar.gz"
+MD5SUM="ed4f32003b71a54ac3d68aa651cb6573"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
+REQUIRES="python3-build"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"