summaryrefslogtreecommitdiffstats
path: root/python/tinycss2/tinycss2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/tinycss2/tinycss2.SlackBuild')
-rw-r--r--python/tinycss2/tinycss2.SlackBuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/python/tinycss2/tinycss2.SlackBuild b/python/tinycss2/tinycss2.SlackBuild
index 1d0d4fab9b..defe1fed00 100644
--- a/python/tinycss2/tinycss2.SlackBuild
+++ b/python/tinycss2/tinycss2.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for tinycss2
-# Copyright 2021 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2021-2024 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=tinycss2
-VERSION=${VERSION:-1.1.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.2.1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,7 +79,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true