summaryrefslogtreecommitdiffstats
path: root/python/tqdm
diff options
context:
space:
mode:
Diffstat (limited to 'python/tqdm')
-rw-r--r--python/tqdm/tqdm.SlackBuild14
-rw-r--r--python/tqdm/tqdm.info8
2 files changed, 14 insertions, 8 deletions
diff --git a/python/tqdm/tqdm.SlackBuild b/python/tqdm/tqdm.SlackBuild
index 4b63275499..59dd3c1566 100644
--- a/python/tqdm/tqdm.SlackBuild
+++ b/python/tqdm/tqdm.SlackBuild
@@ -23,11 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20231221 46and2: Newer setuptools needed to build properly.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=tqdm
-VERSION=${VERSION:-4.64.0}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-4.66.1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
@@ -73,8 +75,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-python3 setup.py install --root=$PKG
+# 46and2: newer setuptools needed
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/tqdm/tqdm.info b/python/tqdm/tqdm.info
index 912f033f6f..fd3b939992 100644
--- a/python/tqdm/tqdm.info
+++ b/python/tqdm/tqdm.info
@@ -1,10 +1,10 @@
PRGNAM="tqdm"
-VERSION="4.64.0"
+VERSION="4.66.1"
HOMEPAGE="https://github.com/tqdm/tqdm"
-DOWNLOAD="https://files.pythonhosted.org/packages/98/2a/838de32e09bd511cf69fe4ae13ffc748ac143449bfc24bb3fd172d53a84f/tqdm-4.64.0.tar.gz"
-MD5SUM="231212e145ac51214286b310704447d4"
+DOWNLOAD="https://files.pythonhosted.org/packages/62/06/d5604a70d160f6a6ca5fd2ba25597c24abd5c5ca5f437263d177ac242308/tqdm-4.66.1.tar.gz"
+MD5SUM="493bb11d0555d04632f7d9be5e5bbe9b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python2-setuptools-scm python-toml"
+REQUIRES="python3-setuptools-opt python3-toml"
MAINTAINER="Dionysis Ntreou"
EMAIL="yakizarns1@gmail.com"