summaryrefslogtreecommitdiffstats
path: root/python/trezor
diff options
context:
space:
mode:
Diffstat (limited to 'python/trezor')
-rw-r--r--python/trezor/README3
-rw-r--r--python/trezor/trezor.SlackBuild18
-rw-r--r--python/trezor/trezor.info2
3 files changed, 17 insertions, 6 deletions
diff --git a/python/trezor/README b/python/trezor/README
index 4f75de70a0..a00ec9f046 100644
--- a/python/trezor/README
+++ b/python/trezor/README
@@ -1 +1,2 @@
-Client side implementation for TREZOR-compatible Bitcoin hardware wallets.
+Client side implementation for TREZOR-compatible Bitcoin hardware
+wallets.
diff --git a/python/trezor/trezor.SlackBuild b/python/trezor/trezor.SlackBuild
index 56c81dc4f2..0de9cd6c29 100644
--- a/python/trezor/trezor.SlackBuild
+++ b/python/trezor/trezor.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for trezor
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=trezor
VERSION=${VERSION:-0.7.9.post1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
SRCNAM=python-$PRGNAM
@@ -37,7 +40,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -71,7 +81,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -84,4 +94,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/trezor/trezor.info b/python/trezor/trezor.info
index d127d74988..55e0b99ce6 100644
--- a/python/trezor/trezor.info
+++ b/python/trezor/trezor.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/trezor/python-trezor/archive/v0.7.9.post1/python-tr
MD5SUM="2bb623c98ef0e5d4eae77fe7b0ecae7d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="ecdsa protobuf mnemonic hidapi"
+REQUIRES="ecdsa protobuf3 mnemonic hidapi"
MAINTAINER="Reedych"
EMAIL="reedych@reedych.pw"