summaryrefslogtreecommitdiffstats
path: root/python/vanguards/vanguards.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/vanguards/vanguards.SlackBuild')
-rw-r--r--python/vanguards/vanguards.SlackBuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/python/vanguards/vanguards.SlackBuild b/python/vanguards/vanguards.SlackBuild
index cb5a9f3d81..619c276b95 100644
--- a/python/vanguards/vanguards.SlackBuild
+++ b/python/vanguards/vanguards.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for vanguards
-# Copyright 2019, Markus Reichelt, Aachen, DE
+# Copyright 2019-2022, Markus Reichelt, Aachen, DE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=vanguards
VERSION=${VERSION:-0.3.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -81,7 +81,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
@@ -94,8 +93,7 @@ cp -a \
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+gzip -9 $PKG/usr/man/man1/*
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc