summaryrefslogtreecommitdiffstats
path: root/python/yara-python/yara-python.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/yara-python/yara-python.SlackBuild')
-rw-r--r--python/yara-python/yara-python.SlackBuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/python/yara-python/yara-python.SlackBuild b/python/yara-python/yara-python.SlackBuild
index 302ef900f0..e78977782e 100644
--- a/python/yara-python/yara-python.SlackBuild
+++ b/python/yara-python/yara-python.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Slackware build script for yara-python
-# Copyright 2017 Barry Grundy <bgrundy[at]linuxleo.com>
+# Copyright 2017-2021 Barry Grundy <bgrundy[at]linuxleo.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,12 +21,12 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
-# New build - v3.5.0, January 2017, Barry J. Grundy.
+# updated - v4.1.2, August 2021, Barry J. Grundy.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=yara-python
-VERSION=${VERSION:-3.5.0}
+VERSION=${VERSION:-4.1.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,8 +82,8 @@ find -L . \
export CC="gcc $SLKCFLAGS $(pkg-config --cflags talloc)"
-python setup.py build --dynamic-linking
-python setup.py install --root=$PKG
+python2 setup.py build --dynamic-linking
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true