summaryrefslogtreecommitdiffstats
path: root/system/OpenSnitch/patches/use-system-python-packages.patch
diff options
context:
space:
mode:
Diffstat (limited to 'system/OpenSnitch/patches/use-system-python-packages.patch')
-rw-r--r--system/OpenSnitch/patches/use-system-python-packages.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/system/OpenSnitch/patches/use-system-python-packages.patch b/system/OpenSnitch/patches/use-system-python-packages.patch
new file mode 100644
index 0000000000..441e01c480
--- /dev/null
+++ b/system/OpenSnitch/patches/use-system-python-packages.patch
@@ -0,0 +1,22 @@
+This patch was taken from Arch Linux repositories:
+https://gitlab.archlinux.org/archlinux/packaging/packages/opensnitch/-/blob/main/use-system-python-packages.patch
+--- a/ui/Makefile
++++ b/ui/Makefile
+@@ -3,16 +3,13 @@ all: opensnitch/resources_rc.py
+ install:
+ @pip3 install --upgrade .
+
+-opensnitch/resources_rc.py: translations deps
++opensnitch/resources_rc.py: translations
+ @pyrcc5 -o opensnitch/resources_rc.py opensnitch/res/resources.qrc
+ sed -i 's/^import ui_pb2/from . import ui_pb2/' opensnitch/ui_pb2*
+
+ translations:
+ @cd i18n ; make
+
+-deps:
+- @pip3 install -r requirements.txt
+-
+ clean:
+ @rm -rf *.pyc
+ @rm -rf opensnitch/resources_rc.py