summaryrefslogtreecommitdiffstats
path: root/system/backintime
diff options
context:
space:
mode:
Diffstat (limited to 'system/backintime')
-rw-r--r--system/backintime/README12
-rw-r--r--system/backintime/backintime.SlackBuild122
-rw-r--r--system/backintime/backintime.info10
-rw-r--r--system/backintime/doinst.sh13
-rw-r--r--system/backintime/slack-desc19
5 files changed, 176 insertions, 0 deletions
diff --git a/system/backintime/README b/system/backintime/README
new file mode 100644
index 0000000000..efc6035ccf
--- /dev/null
+++ b/system/backintime/README
@@ -0,0 +1,12 @@
+Back In Time is a simple backup tool for Linux, inspired by
+"flyback project". It provides a command line client 'backintime'
+and a Qt5 GUI 'backintime-qt' both written in Python3.
+
+You only need to specify 3 things:
+
+ where to save snapshots
+ what folders to back up
+ backup frequency (manual, every hour, every day, every month)
+
+The documentation is currently under development in
+https://backintime.readthedocs.org/
diff --git a/system/backintime/backintime.SlackBuild b/system/backintime/backintime.SlackBuild
new file mode 100644
index 0000000000..69ad099c84
--- /dev/null
+++ b/system/backintime/backintime.SlackBuild
@@ -0,0 +1,122 @@
+#!/bin/bash
+
+# SlackBuild script for Back In Time.
+#
+# Copyright 2022,2023 Fabio Bas <ctrlaltca {at} gmail [dot] com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=backintime
+VERSION=${VERSION:-1.4.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Common components
+cd $TMP/$PRGNAM-$VERSION/common
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ ./configure \
+ # Fix documentation paths
+ sed -i 's|/share/doc/backintime-common|/doc/'$PRGNAM'-'$VERSION'|g' \
+ $TMP/$PRGNAM-$VERSION/common/Makefile
+ make
+ make install DESTDIR=$PKG
+cd -
+
+# Qt5 components
+cd $TMP/$PRGNAM-$VERSION/qt
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ ./configure \
+ # Fix documentation paths
+ sed -i 's|/share/doc/backintime-qt|/doc/'$PRGNAM'-'$VERSION'|g' \
+ $TMP/$PRGNAM-$VERSION/qt/Makefile
+ make
+ make install DESTDIR=$PKG
+cd -
+
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/share/man/ $PKG/usr
+
+# Add slackware documentation in /usr/share/doc/
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README$TAG
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/backintime/backintime.info b/system/backintime/backintime.info
new file mode 100644
index 0000000000..4a2c09afbe
--- /dev/null
+++ b/system/backintime/backintime.info
@@ -0,0 +1,10 @@
+PRGNAM="backintime"
+VERSION="1.4.3"
+HOMEPAGE="https://github.com/bit-team/backintime"
+DOWNLOAD="https://github.com/bit-team/backintime/releases/download/v1.4.3/backintime-1.4.3.tar.gz"
+MD5SUM="421470c6e959f00b6dcbbae6ee08ab05"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Fabio Bas"
+EMAIL="ctrlaltca <at> gmail {dot} com"
diff --git a/system/backintime/doinst.sh b/system/backintime/doinst.sh
new file mode 100644
index 0000000000..aea0f894eb
--- /dev/null
+++ b/system/backintime/doinst.sh
@@ -0,0 +1,13 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/system/backintime/slack-desc b/system/backintime/slack-desc
new file mode 100644
index 0000000000..be4be2a4ab
--- /dev/null
+++ b/system/backintime/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+backintime: backintime (simple backup tool)
+backintime:
+backintime: Back In Time is a simple backup tool for Linux, inspired by
+backintime: "flyback project". It provides a command line client 'backintime'
+backintime: and a Qt5 GUI 'backintime-qt' both written in Python3.
+backintime:
+backintime: You only need to specify 3 things: where to save snapshots, what
+backintime: folders to back up and the backup frequency (manual, every hour,
+backintime: every day, every month)
+backintime:
+backintime: https://github.com/bit-team/backintime