summaryrefslogtreecommitdiffstats
path: root/system/kitty/kitty.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/kitty/kitty.SlackBuild')
-rw-r--r--system/kitty/kitty.SlackBuild60
1 files changed, 28 insertions, 32 deletions
diff --git a/system/kitty/kitty.SlackBuild b/system/kitty/kitty.SlackBuild
index 11ce5a5d6e..81d907d472 100644
--- a/system/kitty/kitty.SlackBuild
+++ b/system/kitty/kitty.SlackBuild
@@ -2,14 +2,17 @@
# Slackware build script for kitty
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (email removed)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20230720 bkw: hand over maintenance to Eugen Wissner.
+# 20221228 bkw: update for v0.26.5, fix sbopkglint gripes.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=kitty
-VERSION=${VERSION:-0.19.3}
+VERSION=${VERSION:-0.34.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -22,9 +25,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -56,53 +56,49 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
+
chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-# The Makefile ain't a real Makefile, everything's done in setup.py. Which
-# has issues:
-# - upstream claims harfbuzz >= 1.5 is required, but 14.2's 1.2 seems to work
-# just fine.
-# - CFLAGS not supported, -O3 hardcoded. The OVERRIDE stuff works, but the
-# hardcoded -O3 comes *after* them on the gcc command line. Grr.
-# - -Werror is used when compiling launcher.c, no way to disable. This assumes
-# upstream is perfect at writing code that compiles without warnings on every
-# version of gcc we might ever happen to use, and I don't believe it.
-# So, sed surgery.
-
-sed -i \
- -e "/at_least_version('harfbuzz/s,5,2," \
- -e 's,-O3,-O2,g' \
- -e 's,-Werror , ,g' \
- setup.py
+# Note to self: don't use the Makefile, it just runs setup.py but
+# doesn't give us a way to pass options to it.
+
+# sed surgery: setup.py allows overriding the compiler flags, but
+# puts a -O3 *after* whatever we set them to. All our SLKCFLAGS
+# choices have -O2.
+
+sed -i 's,-O3,-O2,g' setup.py
# The -Wl,-s makes the linker strip the binaries.
+# --ignore-compiler-warnings is needed to turn off -Werror.
+
OVERRIDE_CPPFLAGS="$SLKCFLAGS -Wl,-s" \
OVERRIDE_CFLAGS="$SLKCFLAGS -Wl,-s" \
- python3 setup.py --libdir-name lib$LIBDIRSUFFIX --verbose linux-package
+ python3 setup.py \
+ --libdir-name lib$LIBDIRSUFFIX \
+ --verbose linux-package \
+ --ignore-compiler-warnings
mkdir -p $PKG/usr/bin $PKG/usr/share $PKG/usr/lib$LIBDIRSUFFIX
cp -a linux-package/bin/* $PKG/usr/bin
cp -a linux-package/share/* $PKG/usr/share
cp -a linux-package/lib*/* $PKG/usr/lib$LIBDIRSUFFIX
+strip $PKG/usr/bin/$PRGNAM
mv $PKG/usr/share/man $PKG/usr/man
gzip $PKG/usr/man/man?/*.?
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-mv $PKG/usr/share/doc/$PRGNAM/html $PKG/usr/doc/$PRGNAM-$VERSION
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+mv $PKG/usr/share/doc/$PRGNAM/html $PKGDOC
rm -rf $PKG/usr/share/doc/
-cp -a CHANGELOG* CONTRIBUTING* README* LICENSE* $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-# make slack-desc reflect the display types the package is built for
-L=$PKG/usr/lib$LIBDIRSUFFIX/$PRGNAM/$PRGNAM
-[ -e $L/glfw-x11.so ] && DISPLAYS+=" X11"
-[ -e $L/glfw-wayland.so ] && DISPLAYS+=" Wayland"
+find $PKGDOC/html -type f -a -empty | xargs rm
+cp -a CHANGELOG* CONTRIBUTING* README* LICENSE* $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
-sed "s,@DISPLAYS@,$DISPLAYS," $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG