summaryrefslogtreecommitdiffstats
path: root/system/memtest86+/patches/memtest86+-5.01-no-clean.patch
diff options
context:
space:
mode:
Diffstat (limited to 'system/memtest86+/patches/memtest86+-5.01-no-clean.patch')
-rw-r--r--system/memtest86+/patches/memtest86+-5.01-no-clean.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/system/memtest86+/patches/memtest86+-5.01-no-clean.patch b/system/memtest86+/patches/memtest86+-5.01-no-clean.patch
new file mode 100644
index 0000000000..e9cbf10399
--- /dev/null
+++ b/system/memtest86+/patches/memtest86+-5.01-no-clean.patch
@@ -0,0 +1,19 @@
+http://forum.canardpc.com/threads/110954-PATCH-fix-parallel-build-issues
+
+
+don't run the clean target when building all as we run into parallel races:
+ - memtest kicks off building of a bunch of .o files
+ - clean runs in parallel which runs `rm` and deletes some of the new .o
+ - memtest goes to link and fails because objects are missing
+
+--- a/Makefile
++++ b/Makefile
+@@ -19,7 +19,7 @@
+ smp.o vmem.o random.o
+
+
+-all: clean memtest.bin memtest
++all: memtest.bin memtest
+
+ # Link it statically once so I know I don't have undefined
+ # symbols and then link it dynamically so I have full