summaryrefslogtreecommitdiffstats
path: root/system/partclone/partclone.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/partclone/partclone.SlackBuild')
-rw-r--r--system/partclone/partclone.SlackBuild18
1 files changed, 16 insertions, 2 deletions
diff --git a/system/partclone/partclone.SlackBuild b/system/partclone/partclone.SlackBuild
index e915716c38..1c669f6ba9 100644
--- a/system/partclone/partclone.SlackBuild
+++ b/system/partclone/partclone.SlackBuild
@@ -22,6 +22,8 @@
# was previously maintained by Kevin Paulus
+# 20230803 bkw: Modified by SlackBuilds.org: fix conflict with dpkg.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=partclone
@@ -56,6 +58,7 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+ FAILMBR="prebuilt" # 20230803 bkw: see below.
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -72,9 +75,20 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
+
+# 20230803 bkw: force use of precompiled fail-mbr.bin, if needed.
+# Without this, the build will fail on x86_64 if dpkg happens to be
+# installed, because our gcc isn't biarch as Debian's is. If dpkg
+# *isn't* installed (the normal case), it just uses the prebuilt
+# binary. All this change does is make it always use the prebuilt
+# fail-mbr.bin on x86_64.
+if [ "$FAILMBR" = "prebuilt" ]; then
+ sed -i 's,sh compile-mbr.sh,cp fail-mbr.bin.orig fail-mbr.bin,' \
+ fail-mbr/Makefile.am
+fi
./autogen