summaryrefslogtreecommitdiffstats
path: root/system/partimage/compilefix.diff
diff options
context:
space:
mode:
Diffstat (limited to 'system/partimage/compilefix.diff')
-rw-r--r--system/partimage/compilefix.diff50
1 files changed, 47 insertions, 3 deletions
diff --git a/system/partimage/compilefix.diff b/system/partimage/compilefix.diff
index 4c84442046..97871ca870 100644
--- a/system/partimage/compilefix.diff
+++ b/system/partimage/compilefix.diff
@@ -1,6 +1,18 @@
+diff -Naur partimage-0.6.9/configure.ac partimage-0.6.9.patched/configure.ac
+--- partimage-0.6.9/configure.ac 2010-07-25 11:30:52.000000000 -0400
++++ partimage-0.6.9.patched/configure.ac 2021-08-24 12:54:23.661280303 -0400
+@@ -240,7 +240,7 @@
+ AC_CHECKING([ for SSL Library and Header files ... ])
+ AC_SEARCH_HEADERS(rsa.h crypto.h x509.h pem.h ssl.h err.h,
+ $SSL_HDR_DIR /usr/include/ssl /usr/include/openssl /usr/include,
+- [ AC_CHECK_LIB(crypto, CRYPTO_lock, [LIBS="$LIBS -lcrypto"],
++ [ AC_CHECK_LIB(crypto, X509_new, [LIBS="$LIBS -lcrypto"],
+ AC_MSG_ERROR([ Required for SSL Crypto Library not found. ])
+ )
+ AC_CHECK_LIB(ssl, SSL_CTX_new,
diff -Naur partimage-0.6.9/src/client/imagefile.cpp partimage-0.6.9.patched/src/client/imagefile.cpp
--- partimage-0.6.9/src/client/imagefile.cpp 2010-07-25 11:30:31.000000000 -0400
-+++ partimage-0.6.9.patched/src/client/imagefile.cpp 2016-10-21 13:28:03.035049317 -0400
++++ partimage-0.6.9.patched/src/client/imagefile.cpp 2021-08-24 12:54:00.205282436 -0400
@@ -783,7 +783,7 @@
else if (m_options.dwCompression == COMPRESS_GZIP) // Gzip compression
{
@@ -21,7 +33,7 @@ diff -Naur partimage-0.6.9/src/client/imagefile.cpp partimage-0.6.9.patched/src/
else
diff -Naur partimage-0.6.9/src/client/imagefile.h partimage-0.6.9.patched/src/client/imagefile.h
--- partimage-0.6.9/src/client/imagefile.h 2010-07-25 11:30:31.000000000 -0400
-+++ partimage-0.6.9.patched/src/client/imagefile.h 2016-10-21 13:28:03.036049317 -0400
++++ partimage-0.6.9.patched/src/client/imagefile.h 2021-08-24 12:54:00.205282436 -0400
@@ -41,7 +41,7 @@
COptions m_options;
@@ -33,7 +45,7 @@ diff -Naur partimage-0.6.9/src/client/imagefile.h partimage-0.6.9.patched/src/cl
int m_nFdImage;
diff -Naur partimage-0.6.9/src/client/misc.h partimage-0.6.9.patched/src/client/misc.h
--- partimage-0.6.9/src/client/misc.h 2010-07-25 11:30:31.000000000 -0400
-+++ partimage-0.6.9.patched/src/client/misc.h 2016-10-21 13:28:09.708049742 -0400
++++ partimage-0.6.9.patched/src/client/misc.h 2021-08-24 12:54:00.206282435 -0400
@@ -36,7 +36,7 @@
#endif
@@ -43,3 +55,35 @@ diff -Naur partimage-0.6.9/src/client/misc.h partimage-0.6.9.patched/src/client/
#endif
// =======================================================
+diff -Naur partimage-0.6.9/src/client/netclient.cpp partimage-0.6.9.patched/src/client/netclient.cpp
+--- partimage-0.6.9/src/client/netclient.cpp 2010-07-25 11:30:31.000000000 -0400
++++ partimage-0.6.9.patched/src/client/netclient.cpp 2021-08-24 12:54:23.662280303 -0400
+@@ -43,7 +43,11 @@
+ {
+ showDebug(3, "initializing client ssl\n");
+ SSLeay_add_ssl_algorithms();
+- meth = SSLv2_client_method();
++#if OPENSSL_VERSION_NUMBER < 0x10100000
++ meth = TLSv1_client_method();
++#else
++ meth = TLS_client_method();
++#endif
+ SSL_load_error_strings();
+ ctx = SSL_CTX_new(meth);
+ if (!ctx)
+diff -Naur partimage-0.6.9/src/server/netserver.cpp partimage-0.6.9.patched/src/server/netserver.cpp
+--- partimage-0.6.9/src/server/netserver.cpp 2010-07-25 11:30:31.000000000 -0400
++++ partimage-0.6.9.patched/src/server/netserver.cpp 2021-08-24 12:54:23.662280303 -0400
+@@ -39,7 +39,11 @@
+ {
+ SSL_load_error_strings();
+ SSLeay_add_ssl_algorithms();
+- meth = SSLv23_server_method();
++#if OPENSSL_VERSION_NUMBER < 0x10100000
++ meth = TLSv1_server_method();
++#else
++ meth = TLS_server_method();
++#endif
+ ctx = SSL_CTX_new(meth);
+ if (!ctx)
+ {