summaryrefslogtreecommitdiffstats
path: root/system/patool/patool.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/patool/patool.SlackBuild')
-rw-r--r--system/patool/patool.SlackBuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/system/patool/patool.SlackBuild b/system/patool/patool.SlackBuild
index d31a96201c..e493b900a9 100644
--- a/system/patool/patool.SlackBuild
+++ b/system/patool/patool.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for patool
-# Copyright 2014-2022 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2023 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=patool
-VERSION=${VERSION:-1.12}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.15.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,12 +79,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# patch to install man page in correct place
-sed -i 's/share\/man/\/usr\/man/' setup.py
-
-python setup.py install --root=$PKG
python3 setup.py install --root=$PKG
+mkdir -p $PKG/usr/man/man1
+cp doc/$PRGNAM.1 $PKG/usr/man/man1
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true