summaryrefslogtreecommitdiffstats
path: root/system/sbsigntools/sbsigntools.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/sbsigntools/sbsigntools.SlackBuild')
-rw-r--r--system/sbsigntools/sbsigntools.SlackBuild32
1 files changed, 16 insertions, 16 deletions
diff --git a/system/sbsigntools/sbsigntools.SlackBuild b/system/sbsigntools/sbsigntools.SlackBuild
index 7f5deaac5f..9146f824f6 100644
--- a/system/sbsigntools/sbsigntools.SlackBuild
+++ b/system/sbsigntools/sbsigntools.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for sbsigntools
# Copyright 2015 Jonathan Li
+# Copyright 2023 Sam Wright
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +23,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20231211 bkw:
+# - update for v0.9.5.
+# - new maintainer (who isn't me, for once!)
+# - remove 0-byte ChangeLog from doc dir.
+# - various minor tweaks.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sbsigntools
-VERSION=${VERSION:-0.9.1}
+VERSION=${VERSION:-0.9.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +45,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -70,15 +74,16 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-# The tarball is generated from a clone --recursive of the git repository
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+# The tarball is generated from a clone --recursive of the git repository,
+# see git2tarxz.sh.
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
sed -i "s|/usr/lib$LIBDIRSUFFIX/efi|/usr/lib$LIBDIRSUFFIX/gnuefi|" configure.ac
@@ -95,16 +100,11 @@ CXXFLAGS="$SLKCFLAGS" \
cp lib/ccan.git/config.h lib/ccan
make
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+make install-strip DESTDIR=$PKG
+gzip -9 $PKG/usr/man/man*/*
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING LICENSE.GPLv3 ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING LICENSE.GPLv3 $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install