summaryrefslogtreecommitdiffstats
path: root/system/tabbed
diff options
context:
space:
mode:
Diffstat (limited to 'system/tabbed')
-rw-r--r--system/tabbed/README5
-rw-r--r--system/tabbed/tabbed.SlackBuild30
-rw-r--r--system/tabbed/tabbed.info6
3 files changed, 20 insertions, 21 deletions
diff --git a/system/tabbed/README b/system/tabbed/README
index 8fba968b50..fba5e0c832 100644
--- a/system/tabbed/README
+++ b/system/tabbed/README
@@ -5,7 +5,7 @@ originally designed for surf but also usable with many other
applications, e.g. st, uzbl, urxvt, and xterm.
Recommended dependency: dmenu. tabbed is still useful without it, but
-the control-T "new tab" function won't work without it.
+the control-` function won't work without it.
The default width and height for the tabbed window are hard-coded in
the application, and can be set by setting WIDTH and HEIGHT environment
@@ -13,5 +13,8 @@ variables. Default size is 800x600. Example:
WIDTH=1024 HEIGHT=768 ./tabbed.SlackBuild
+Note that the above only sets the default; you can use the -g option
+to set the geometry, no matter what the default is.
+
For other customizations, you can create a diff and place it in
patches/. See README.SBo for details.
diff --git a/system/tabbed/tabbed.SlackBuild b/system/tabbed/tabbed.SlackBuild
index 5463456635..765f55d439 100644
--- a/system/tabbed/tabbed.SlackBuild
+++ b/system/tabbed/tabbed.SlackBuild
@@ -6,6 +6,9 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20240730 bkw: update for 0.8
+# 20221228 bkw: update for 0.7
+
# 20140826 bkw:
# - updated for 0.6
# - add support for patches/. The old 0.4 build had this, but this one
@@ -15,7 +18,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=tabbed
-VERSION=${VERSION:-0.6}
+VERSION=${VERSION:-0.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,16 +42,12 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
fi
set -e
@@ -66,7 +65,7 @@ find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
# Apply any patches the user might have added. This is more complex
# than usual because we want to detect whether each patch needs -p0
# or -p1.
-for i in $( ls $CWD/patches ); do
+for i in $( ls $CWD/patches 2>/dev/null || true ); do
p=""
diff=$CWD/patches/$i
@@ -84,24 +83,21 @@ for i in $( ls $CWD/patches ); do
done
sed -i \
- -e 's,share/man,man,' \
- -e 's,usr/local,usr/,' \
- -e "s,/usr/lib,/usr/lib$LIBDIRSUFFIX," \
- -e "s,-O0,$SLKCFLAGS," \
- config.mk
-
-sed -i \
-e "/ww *= *800/s,800,${WIDTH:-800}," \
-e "/wh *= *600/s,600,${HEIGHT:-600}," \
$PRGNAM.c
-make
-strip $PRGNAM
-make install DESTDIR=$PKG
+make install \
+ CFLAGS="$SLKCFLAGS"\
+ PREFIX=/usr\
+ MANPREFIX=/usr/man\
+ DOCPREFIX=/usr/doc/$PRGNAM-$VERSION\
+ DESTDIR=$PKG
+strip $PKG/usr/bin/*
gzip -9 $PKG/usr/man/man?/*.?
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README TODO $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/system/tabbed/tabbed.info b/system/tabbed/tabbed.info
index 0504b00e06..1895d8c056 100644
--- a/system/tabbed/tabbed.info
+++ b/system/tabbed/tabbed.info
@@ -1,8 +1,8 @@
PRGNAM="tabbed"
-VERSION="0.6"
+VERSION="0.8"
HOMEPAGE="https://tools.suckless.org/tabbed/"
-DOWNLOAD="https://dl.suckless.org/tools/tabbed-0.6.tar.gz"
-MD5SUM="7898992feb9358e0196119750b77b42c"
+DOWNLOAD="https://dl.suckless.org/tools/tabbed-0.8.tar.gz"
+MD5SUM="4f9aaff184d13456824f8dfba97d9527"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""