summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-09-14 16:52:07 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-17 00:10:34 +0700
commite9bb2d5d02ec54f6d945b9930b1f8f7abdd7f88c (patch)
treeb94e10feaf0cdb5f4c0a9d48437b2a0bbb6b402d
parent5881303c007ee3209dca1ddd8f7442643009ad15 (diff)
downloadslackbuilds-e9bb2d5d02ec54f6d945b9930b1f8f7abdd7f88c.tar.gz
slackbuilds-e9bb2d5d02ec54f6d945b9930b1f8f7abdd7f88c.tar.xz
python/werkzeug: Updated for version 2.3.7.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/werkzeug/werkzeug.SlackBuild28
-rw-r--r--python/werkzeug/werkzeug.info8
2 files changed, 20 insertions, 16 deletions
diff --git a/python/werkzeug/werkzeug.SlackBuild b/python/werkzeug/werkzeug.SlackBuild
index 199363f350..00a9240ac2 100644
--- a/python/werkzeug/werkzeug.SlackBuild
+++ b/python/werkzeug/werkzeug.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for werkzeug
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2013 Mohamed LYAHYAOUI <mlyahyaoui@gmail.com>
# Copyright 2018-2020 Dominik Drobek <dominik.drobek (at) o2.pl>
# All rights reserved.
@@ -25,12 +25,12 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# 20220512 46and2: Updated version, new maintainer.
+# 20230914 46and2: Updated version, change build process.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=werkzeug
-SRCNAM=Werkzeug
-VERSION=${VERSION:-2.1.2}
+VERSION=${VERSION:-2.3.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -43,9 +43,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -64,6 +61,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -74,17 +74,21 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# relax version required
+sed -i '/MarkupSafe/ s/2\.1\.1/2.0.1/' pyproject.toml
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/werkzeug/werkzeug.info b/python/werkzeug/werkzeug.info
index 2c3ca8e009..7d3d0dc3f6 100644
--- a/python/werkzeug/werkzeug.info
+++ b/python/werkzeug/werkzeug.info
@@ -1,10 +1,10 @@
PRGNAM="werkzeug"
-VERSION="2.1.2"
+VERSION="2.3.7"
HOMEPAGE="https://palletsprojects.com/p/werkzeug/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/w/werkzeug/Werkzeug-2.1.2.tar.gz"
-MD5SUM="5835c8738b8081c53367cbcc5db8784c"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/w/werkzeug/werkzeug-2.3.7.tar.gz"
+MD5SUM="31bb8f7f0be8724e6da89df0f6fc5d12"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-build"
MAINTAINER="fourtysixandtwo"
EMAIL="fourtysixandtwo@sliderr.net"