summaryrefslogtreecommitdiffstats
path: root/python/python3-django
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-django')
-rw-r--r--python/python3-django/README9
-rw-r--r--python/python3-django/python3-django.SlackBuild26
-rw-r--r--python/python3-django/python3-django.info10
3 files changed, 28 insertions, 17 deletions
diff --git a/python/python3-django/README b/python/python3-django/README
index 5d7090a375..8749f20060 100644
--- a/python/python3-django/README
+++ b/python/python3-django/README
@@ -1,4 +1,5 @@
-Django is a high-level Python Web framework that encourages rapid development
-and clean, pragmatic design. Built by experienced developers, it takes care of
-much of the hassle of Web development, so you can focus on writing your app
-without needing to reinvent the wheel. It’s free and open source.
+Django is a high-level Python Web framework that encourages rapid
+development and clean, pragmatic design. Built by experienced
+developers, it takes care of much of the hassle of Web development,
+so you can focus on writing your app without needing to reinvent the
+wheel. It’s free and open source.
diff --git a/python/python3-django/python3-django.SlackBuild b/python/python3-django/python3-django.SlackBuild
index b3c79e0970..990dc76cae 100644
--- a/python/python3-django/python3-django.SlackBuild
+++ b/python/python3-django/python3-django.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for python3-django
-# Copyright 2018-2020 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2018-2024 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,11 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=python3-django
SRCNAM=$(echo $PRGNAM | cut -c9-14)
-VERSION=${VERSION:-3.0.3}
+VERSION=${VERSION:-4.2.9}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +39,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -73,9 +83,9 @@ find -L . \
python3 setup.py install --root=$PKG
# Install bash completion file
-mkdir -p $PKG/etc/bash_completion.d
-install -D -m0744 extras/${SRCNAM}_bash_completion \
- $PKG/etc/bash_completion.d/${SRCNAM}_bash_completion
+mkdir -p $PKG/usr/share/bash-completion/completions
+install -D -m0644 extras/${SRCNAM}_bash_completion \
+ $PKG/usr/share/bash-completion/completions/${SRCNAM}
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS CONTRIBUTING.rst INSTALL LICENSE README.rst \
@@ -86,4 +96,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-django/python3-django.info b/python/python3-django/python3-django.info
index e9fc1d32e5..f605f2ff0f 100644
--- a/python/python3-django/python3-django.info
+++ b/python/python3-django/python3-django.info
@@ -1,10 +1,10 @@
PRGNAM="python3-django"
-VERSION="3.0.3"
+VERSION="4.2.9"
HOMEPAGE="https://www.djangoproject.com/"
-DOWNLOAD="https://github.com/django/django/archive/3.0.3/django-3.0.3.tar.gz"
-MD5SUM="51b9c3579a8a389f8a3be5b1cb2bd199"
+DOWNLOAD="https://github.com/django/django/archive/4.2.9/django-4.2.9.tar.gz"
+MD5SUM="653896818a682e045188fb8af5e335a0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="pytz sqlparse asgiref"
+REQUIRES="sqlparse asgiref"
MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+EMAIL="dslackw@gmail.com"