summaryrefslogtreecommitdiffstats
path: root/system/I-Nex
diff options
context:
space:
mode:
Diffstat (limited to 'system/I-Nex')
-rw-r--r--system/I-Nex/I-Nex.SlackBuild52
-rw-r--r--system/I-Nex/I-Nex.info8
-rw-r--r--system/I-Nex/I-Nex_fix.patch23
-rw-r--r--system/I-Nex/i-nex-library.desktop10
-rw-r--r--system/I-Nex/i-nex.desktop10
5 files changed, 62 insertions, 41 deletions
diff --git a/system/I-Nex/I-Nex.SlackBuild b/system/I-Nex/I-Nex.SlackBuild
index a094087108..246848795d 100644
--- a/system/I-Nex/I-Nex.SlackBuild
+++ b/system/I-Nex/I-Nex.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for I-Nex
@@ -22,10 +22,23 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220331 bkw: Modified by SlackBuilds.org, BUILD=3:
+# - don't install .desktop files +x.
+# - make /usr/bin/i-nex symlink relative.
+
+# 20220212 bkw: Modified by SlackBuilds.org: BUILD=2.
+# - add -j1 to 'make install' to avoid breaking parallel builds.
+# - fix the .desktop files
+# - install the rest of the docs (AUTHORS, ChangeLog).
+# - don't install useless INSTALL to doc dir.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=I-Nex
-VERSION=${VERSION:-7.6.0}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-7.6.1}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +48,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -65,15 +82,12 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-sed -i 's|python3$|python2|' pastebinit
sed -i -e 's|^STATIC.*|STATIC = false|' i-nex.mk
-patch -p1 -i $CWD/I-Nex_fix.patch
-
cd $PRGNAM
autoreconf --install
@@ -89,15 +103,25 @@ CFLAGS="$SLKCFLAGS" \
cd ..
make
-make install DESTDIR=$PKG
+make -j1 install DESTDIR=$PKG
+strip $PKG/usr/bin/i-nex-edid
+
+# the shipped .desktop files don't validate, and are silly. also they
+# get installed executable...
+rm -f $PKG/usr/share/applications/*
+for i in $CWD/*.desktop; do
+ cat $i > $PKG/usr/share/applications/$( basename $i )
+done
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# 20220331 bkw: this symlink should be relative, not absolute.
+rm -f $PKG/usr/bin/i-nex
+ln -s i-nex.gambas $PKG/usr/bin/i-nex
+rm -rf $PKG/usr/share/doc
mv $PKG/usr/share/man/ $PKG/usr/
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $PRGNAM/COPYING $PRGNAM/INSTALL $PRGNAM/README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $PRGNAM/{AUTHORS,COPYING,ChangeLog,README} $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
@@ -105,4 +129,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/I-Nex/I-Nex.info b/system/I-Nex/I-Nex.info
index 33cd77088d..b7088894d4 100644
--- a/system/I-Nex/I-Nex.info
+++ b/system/I-Nex/I-Nex.info
@@ -1,10 +1,10 @@
PRGNAM="I-Nex"
-VERSION="7.6.0"
+VERSION="7.6.1"
HOMEPAGE="https://github.com/eloaders/I-Nex"
-DOWNLOAD="https://github.com/i-nex/I-Nex/archive/7.6.0/I-Nex-7.6.0.tar.gz"
-MD5SUM="4fd4686e860b7dc47c8baccce5764d3b"
+DOWNLOAD="https://github.com/i-nex/I-Nex/archive/7.6.1/I-Nex-7.6.1.tar.gz"
+MD5SUM="03c2622075c15f24b3b3fa5dd7cf3597"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="qt5 gambas3 libcpuid"
+REQUIRES="gambas3 libcpuid"
MAINTAINER="Cristiano Urban"
EMAIL="cristiano.urban.slack@gmail.com"
diff --git a/system/I-Nex/I-Nex_fix.patch b/system/I-Nex/I-Nex_fix.patch
deleted file mode 100644
index bdf439f84f..0000000000
--- a/system/I-Nex/I-Nex_fix.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/I-Nex/i-nex/.src/Finfosys.class 2019-09-28 17:03:37.613473723 +0200
-+++ b/I-Nex/i-nex/.src/Finfosys.class 2019-09-28 17:04:45.017472516 +0200
-@@ -322,6 +322,7 @@
- Public Sub System()
- Dim hostname, arch, gcc, timezone, xorg_version, glx_version As String
- Dim SCREENFETCH_P As Process
-+ Dim sLine2 As String
- SCREENFETCH_P = Exec ["" & ChkPrm.ChkExecDir("bash") & ""] For Write
- Write #SCREENFETCH_P, File.Load("Data/screenfetch-dev")
- SCREENFETCH_P.Wait
-@@ -332,9 +333,9 @@
- Shell "timedatectl status | grep \"Time zone:\" | cut -d \":\" -f 2 | cut -d \"(\" -f 1" Wait To timezone
- Endif
- 'Detect heap size
-- For Each sLine In Split(File.Load("/proc/self/maps"), "\n")
-- If InStr(sLine, "[heap]") Then
-- aScan = Scan(sLine, "*-* *")
-+ For Each sLine2 In Split(File.Load("/proc/self/maps"), "\n")
-+ If InStr(sLine2, "[heap]") Then
-+ aScan = Scan(sLine2, "*-* *")
- Label176.Text = "Heap size is " & Format(Val("&H" & aScan[1] & "&") - Val("&H" & aScan[0] & "&"), "#,##0") & " bytes."
- Break
- Endif
diff --git a/system/I-Nex/i-nex-library.desktop b/system/I-Nex/i-nex-library.desktop
new file mode 100644
index 0000000000..2b488642dc
--- /dev/null
+++ b/system/I-Nex/i-nex-library.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=I-Nex Library
+Comment=I-Nex System Library Information.
+Exec=/usr/bin/i-nex.gambas --library
+Icon=/usr/share/pixmaps/i-nex-32.png
+Terminal=false
+StartupNotify=true
+Type=Application
+Categories=System;
+Version=1.0
diff --git a/system/I-Nex/i-nex.desktop b/system/I-Nex/i-nex.desktop
new file mode 100644
index 0000000000..46e1f1fc7e
--- /dev/null
+++ b/system/I-Nex/i-nex.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=I-Nex
+Comment=I-Nex Viewing System Device Information.
+Exec=/usr/bin/i-nex.gambas
+Icon=/usr/share/pixmaps/i-nex-32.png
+Terminal=false
+StartupNotify=true
+Type=Application
+Categories=System;
+Version=1.0