summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-27 07:36:28 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-27 07:36:28 +0700
commit0dd86904e966d3ba360985af776a0e8eb93d3246 (patch)
treebac8010e6437175b12653f614e19305d4422f458
parent3fe91359da659f6996b3bd519040b14dbb7f1081 (diff)
downloadslackbuilds-0dd86904e966d3ba360985af776a0e8eb93d3246.tar.gz
slackbuilds-0dd86904e966d3ba360985af776a0e8eb93d3246.tar.xz
network/EarthReader-Web: Add Python3 support.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/EarthReader-Web/EarthReader-Web.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/network/EarthReader-Web/EarthReader-Web.SlackBuild b/network/EarthReader-Web/EarthReader-Web.SlackBuild
index 40e77169a7..53d1dbd0f9 100644
--- a/network/EarthReader-Web/EarthReader-Web.SlackBuild
+++ b/network/EarthReader-Web/EarthReader-Web.SlackBuild
@@ -69,7 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true